From dafdee8adbab9a5bb7455b4aa2c6a594c149e315 Mon Sep 17 00:00:00 2001
From: Michael Cummings <mcummings@gentoo.org>
Date: Fri, 8 Dec 2006 14:28:20 +0000
Subject: Added animated GIF support, thanks to jamasi for tracking this down
 Package-Manager: portage-2.1.2_rc2-r3

---
 dev-perl/GD/GD-2.35-r1.ebuild | 38 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 38 insertions(+)
 create mode 100644 dev-perl/GD/GD-2.35-r1.ebuild

(limited to 'dev-perl/GD/GD-2.35-r1.ebuild')

diff --git a/dev-perl/GD/GD-2.35-r1.ebuild b/dev-perl/GD/GD-2.35-r1.ebuild
new file mode 100644
index 000000000000..f24be63250f9
--- /dev/null
+++ b/dev-perl/GD/GD-2.35-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/GD/GD-2.35-r1.ebuild,v 1.1 2006/12/08 14:28:20 mcummings Exp $
+
+inherit eutils perl-module
+
+DESCRIPTION="interface to Thomas Boutell's gd library"
+HOMEPAGE="http://www.cpan.org/modules/by-module/GD/${P}.readme"
+SRC_URI="mirror://cpan/authors/id/L/LD/LDS/${P}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="animgif gif jpeg png truetype xpm"
+
+DEPEND=">=media-libs/gd-2.0.28
+	png? ( media-libs/libpng sys-libs/zlib )
+	jpeg? ( media-libs/jpeg )
+	truetype? ( =media-libs/freetype-2* )
+	xpm? ( || ( x11-libs/libXpm virtual/x11 ) )
+	gif? ( media-libs/giflib )
+	dev-lang/perl"
+
+src_compile() {
+	myconf=""
+	use gif && use animgif && myconf="${myconf},ANIMGIF"
+	use jpeg && myconf="${myconf},JPEG"
+	use truetype && myconf="${myconf},FREETYPE"
+	use png && myconf="${myconf},PNG"
+	use xpm && myconf="${myconf},XPM"
+	use gif && myconf="${myconf},GIF"
+	myconf="-options \"${myconf:1}\""
+	perl-module_src_compile
+}
+
+mydoc="GD.html"
+
+
-- 
cgit v1.2.3-65-gdbad