From d45a9c2474250ae1ea02dfe79e352915b02d98e8 Mon Sep 17 00:00:00 2001
From: Hans de Graaff <graaff@gentoo.org>
Date: Fri, 13 May 2011 06:28:06 +0000
Subject: Version bump.

Package-Manager: portage-2.1.9.42/cvs/Linux x86_64
---
 dev-ruby/addressable/ChangeLog                |  7 +++++-
 dev-ruby/addressable/addressable-2.2.6.ebuild | 36 +++++++++++++++++++++++++++
 2 files changed, 42 insertions(+), 1 deletion(-)
 create mode 100644 dev-ruby/addressable/addressable-2.2.6.ebuild

(limited to 'dev-ruby/addressable')

diff --git a/dev-ruby/addressable/ChangeLog b/dev-ruby/addressable/ChangeLog
index c6b114a6909f..02b1a02736d6 100644
--- a/dev-ruby/addressable/ChangeLog
+++ b/dev-ruby/addressable/ChangeLog
@@ -1,6 +1,11 @@
 # ChangeLog for dev-ruby/addressable
 # Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/addressable/ChangeLog,v 1.16 2011/04/10 06:10:22 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/addressable/ChangeLog,v 1.17 2011/05/13 06:25:34 graaff Exp $
+
+*addressable-2.2.6 (13 May 2011)
+
+  13 May 2011; Hans de Graaff <graaff@gentoo.org> +addressable-2.2.6.ebuild:
+  Version bump.
 
 *addressable-2.2.5 (10 Apr 2011)
 
diff --git a/dev-ruby/addressable/addressable-2.2.6.ebuild b/dev-ruby/addressable/addressable-2.2.6.ebuild
new file mode 100644
index 000000000000..ce5e2c4da58e
--- /dev/null
+++ b/dev-ruby/addressable/addressable-2.2.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/addressable/addressable-2.2.6.ebuild,v 1.1 2011/05/13 06:25:34 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ruby19 jruby ree18"
+
+RUBY_FAKEGEM_TASK_DOC="doc:rdoc"
+RUBY_FAKEGEM_TASK_TEST="spec:normal"
+
+RAKE_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A replacement for the URI implementation that is part of Ruby's standard library."
+HOMEPAGE="http://addressable.rubyforge.org/"
+
+LICENSE="as-is"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/rspec:0 )"
+
+each_ruby_test() {
+	case ${RUBY} in
+		*jruby)
+			ewarn "Tests disabled because they crash jruby."
+			;;
+		*)
+			each_fakegem_test
+			;;
+	esac
+}
-- 
cgit v1.2.3-65-gdbad