From 781eb3d883dbb64a4eece9486fa393925592d10d Mon Sep 17 00:00:00 2001
From: Martin Holzer <mholzer@gentoo.org>
Date: Wed, 16 Apr 2003 23:04:21 +0000
Subject: Version bumped.

---
 net-news/inn/Manifest               |   3 +-
 net-news/inn/files/digest-inn-2.3.5 |   2 +
 net-news/inn/inn-2.3.5.ebuild       | 110 ++++++++++++++++++++++++++++++++++++
 3 files changed, 113 insertions(+), 2 deletions(-)
 create mode 100644 net-news/inn/files/digest-inn-2.3.5
 create mode 100644 net-news/inn/inn-2.3.5.ebuild

(limited to 'net-news/inn')

diff --git a/net-news/inn/Manifest b/net-news/inn/Manifest
index c0bfc32d49bd..9749cd380764 100644
--- a/net-news/inn/Manifest
+++ b/net-news/inn/Manifest
@@ -1,7 +1,6 @@
-MD5 7a42fbdc8430d20f706f67bf97ade0ee ChangeLog 605
+MD5 0bb031a7eaac2ae6c70d5b4ed9453d42 ChangeLog 805
 MD5 467ccd3a1d701369cff59232cffa116c inn-2.3.3.ebuild 1910
 MD5 4855446440deef3d6783f921d0311041 inn-2.3.5.ebuild 2928
 MD5 5e094ec9d89dc4d773f912de4d3464dc files/digest-inn-2.3.3 62
 MD5 4f9a1244cbdae832eba7fd71631d77c9 files/innd 504
 MD5 ce3c00651e354a874cc9c60ae4f0255e files/digest-inn-2.3.5 128
-MD5 d8a45b17cd7450ae2541fac311bff33b files/inn-2.3.5-gentoo.tar.gz 4536
diff --git a/net-news/inn/files/digest-inn-2.3.5 b/net-news/inn/files/digest-inn-2.3.5
new file mode 100644
index 000000000000..9df419526121
--- /dev/null
+++ b/net-news/inn/files/digest-inn-2.3.5
@@ -0,0 +1,2 @@
+MD5 97223e05d37e568f2ba95793b8133246 inn-2.3.5.tar.gz 1421702
+MD5 d8a45b17cd7450ae2541fac311bff33b inn-2.3.5-gentoo.tar.gz 4536
diff --git a/net-news/inn/inn-2.3.5.ebuild b/net-news/inn/inn-2.3.5.ebuild
new file mode 100644
index 000000000000..faacacd2a9a1
--- /dev/null
+++ b/net-news/inn/inn-2.3.5.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+#
+
+IUSE="ssl tcltk"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="The Internet News daemon, fully featured NNTP server"
+SRC_URI="ftp://ftp.isc.org/isc/inn/${P}.tar.gz
+	mirror://gentoo/${P}-gentoo.tar.gz"
+HOMEPAGE="http://www.isc.org/products/INN"
+
+SLOT="0"
+LICENSE="as-is BSD"
+KEYWORDS="~x86"
+
+DEPEND="app-crypt/gnupg
+	virtual/mta
+	tcltk? ( dev-lang/tcl )
+	ssl? ( dev-libs/openssl )"
+
+src_compile() {
+	local myconf
+	use tcltk && myconf="${myconf} --with-tcl"
+	use ssl && myconf="${myconf} --with-openssl"
+
+	unset CFLAGS CXXFLAGS
+	./configure --prefix=/usr/lib/news \
+		--mandir=/usr/share/man \
+		--infodir=/usr/share/info \
+		--with-etc-dir=/etc/news \
+		--with-db-dir=/var/spool/news/db \
+		--with-spool-dir=/var/spool/news \
+		--with-log-dir=/var/log/news \
+		--with-run-dir=/var/run/news \
+		--with-tmp-path=/var/spool/news/tmp \
+		--host=${CHOST}  \
+		--enable-libtool \
+		--enable-setgid-inews \
+		--enable-uucp-rnews \
+		--with-gnu-ld \
+		--with-python \
+		--without-perl \
+		${myconf} || die "configure died"
+
+	OLD_P=${P}
+	unset P
+	make || die
+	P=${OLD_P}
+}
+
+src_install() {
+	OLD_P=${P}
+	unset P
+	make prefix=${D}/usr/lib/news \
+		PATHETC=${D}/etc/news \
+		PATHMAN=${D}/usr/share/man \
+		PATHLIB=${D}/usr/lib/news/lib \
+		PATHCONTROL=${D}/usr/lib/news/bin/control \
+		PATHFILTER=${D}/usr/lib/news/bin/filter \
+		PATHRUN=${D}/var/run/news \
+		PATHLOG=${D}/var/log/news \
+		PATHDB=${D}/var/spool/news/db \
+		PATHSPOOL=${D}/var/spool/news \
+		PATHTMP=${D}/var/spool/news/tmp \
+		install || die "make died"
+	P=${OLD_P}
+
+	keepdir /var/spool/news/tmp/
+	keepdir /var/spool/news/outgoing/
+	keepdir /var/spool/news/overview/
+	keepdir /var/spool/news/innfeed/
+	keepdir /var/spool/news/articles/
+	keepdir /var/spool/news/incoming/
+	keepdir /var/spool/news/incoming/bad/
+	keepdir /var/spool/news/archive/
+	keepdir /var/run/news/
+	keepdir /var/log/news/
+
+	dodoc CONTRIBUTORS ChangeLog HACKING HISTORY INSTALL LICENSE
+	dodoc MANIFEST NEWS README*
+	dodoc doc/control-messages doc/sample-control
+
+# So other programs can build against INN.  (eg. Suck)
+	insinto /usr/lib/news/include
+	doins include/*.h
+
+	exeinto /etc/init.d
+	newexe ${FILESDIR}/innd innd
+
+	cd ${WORKDIR}
+	doman send-uucp.pl.8.gz
+	insinto /etc/news
+	doins send-uucp.cf 
+	exeinto /usr/lib/news/bin
+	newexe send-uucp.pl send-uucp.pl
+}
+
+pkg_postinst() {
+	chown news.news ${ROOT}/etc/news/send-uucp.cf
+	chown news.news ${ROOT}/usr/lib/news/bin/send-uucp.pl
+	chown -R news.news ${ROOT}/var/spool/news
+	chown -R news.news ${ROOT}/var/log/news/
+
+	einfo 'Do not forget to update your cron entries, and also run'
+	einfo 'makedbz if you need to.  If this is a first-time installation'
+	einfo 'a minimal active file has been installed.  You will need to'
+	einfo 'touch history and run "makedbz -i" to initialize the history'
+	einfo 'database.  See INSTALL for more information.'
+}
-- 
cgit v1.2.3-65-gdbad