From 070dbb474f9a2aad93a59f4eea7ddacc8e446ae7 Mon Sep 17 00:00:00 2001
From: Joel Hill <hillster@gentoo.org>
Date: Thu, 9 Oct 2003 22:03:10 +0000
Subject: version bump

---
 sys-apps/file/Manifest               |  4 ++--
 sys-apps/file/file-4.05.ebuild       | 40 ++++++++++++++++++++++++++++++++++++
 sys-apps/file/files/digest-file-4.05 |  1 +
 3 files changed, 43 insertions(+), 2 deletions(-)
 create mode 100644 sys-apps/file/file-4.05.ebuild
 create mode 100644 sys-apps/file/files/digest-file-4.05

(limited to 'sys-apps')

diff --git a/sys-apps/file/Manifest b/sys-apps/file/Manifest
index 6cb2ea5be7f2..d531da73a0a9 100644
--- a/sys-apps/file/Manifest
+++ b/sys-apps/file/Manifest
@@ -1,10 +1,10 @@
-MD5 8a4aaf48640c534e4214623f667eef42 file-4.05.ebuild 1047
+MD5 3915a1e133a1c236deb96296b725182e file-4.05.ebuild 1048
 MD5 864d9d78ae48573d790cc598fcc4bc40 file-3.41.ebuild 1025
 MD5 9199c0027f82ae3e018e2415de888492 file-3.37.ebuild 870
 MD5 e593a4a7dea3146bb413dea1737d48b6 file-4.02.ebuild 1093
 MD5 11c4331cb3a68b4bd5250959127e31c0 file-3.39.ebuild 1008
 MD5 20dd962c51a7b039d867a7a99645fbb5 file-4.01.ebuild 936
-MD5 b57d84d2f168f07b2b28ff43783beff7 ChangeLog 2694
+MD5 2761893a5485af2f4b8ae98aa4837e0a ChangeLog 2697
 MD5 eaf31df54d9fcbb759afd4c5e6dcfc7e file-4.03.ebuild 1102
 MD5 aff834708f034a4995abba4192e79583 files/file-3.39-gentoo.diff 4673
 MD5 aff834708f034a4995abba4192e79583 files/file-3.41-mips-gentoo.diff 4673
diff --git a/sys-apps/file/file-4.05.ebuild b/sys-apps/file/file-4.05.ebuild
new file mode 100644
index 000000000000..9a901e143a45
--- /dev/null
+++ b/sys-apps/file/file-4.05.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.05.ebuild,v 1.1 2003/10/09 22:03:05 hillster Exp $
+
+inherit flag-o-matic
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Program to identify a file's format by scanning binary data for patterns"
+SRC_URI="ftp://ftp.gw.com/mirrors/pub/unix/file/${P}.tar.gz
+	ftp://ftp.astron.com/pub/file/${P}.tar.gz"
+HOMEPAGE="ftp://ftp.astron.com/pub/file/"
+
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~arm ~alpha ~hppa ~ia64"
+SLOT="0"
+LICENSE="as-is"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+
+	# file command segfaults on hppa -  reported by gustavo@zacarias.com.ar
+	[ ${ARCH} = "hppa" ] && filter-flags "-mschedule=8000"
+
+	./configure --prefix=/usr \
+		--mandir=/usr/share/man \
+		--datadir=/usr/share/misc \
+		--host=${CHOST} || die
+
+	emake || die
+}
+
+src_install() {
+	make DESTDIR=${D} install || die
+
+	if [ -z "`use build`" ] ; then
+		dodoc LEGAL.NOTICE MAINT README || die
+	else
+		rm -rf ${D}/usr/share/man
+	fi
+}
diff --git a/sys-apps/file/files/digest-file-4.05 b/sys-apps/file/files/digest-file-4.05
new file mode 100644
index 000000000000..0e968be8ad68
--- /dev/null
+++ b/sys-apps/file/files/digest-file-4.05
@@ -0,0 +1 @@
+MD5 24c5f0be601089486f3d55b1e1f9ed48 file-4.05.tar.gz 347269
-- 
cgit v1.2.3-65-gdbad