aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2022-08-28 19:09:33 +0200
committerHaelwenn (lanodan) Monnier <contact@hacktivis.me>2022-08-30 00:49:28 +0200
commit05c3f807343685bc14c934faf9796bf348840514 (patch)
treed50c913db9457cf35b521cc4574c481d2fe73652 /dev-python/wheezy-template
parentapp-misc/lf: update SRC_URI (diff)
downloadguru-05c3f807343685bc14c934faf9796bf348840514.tar.gz
guru-05c3f807343685bc14c934faf9796bf348840514.tar.bz2
guru-05c3f807343685bc14c934faf9796bf348840514.zip
dev-python/wheezy-template: new package, add 3.1.0
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me>
Diffstat (limited to 'dev-python/wheezy-template')
-rw-r--r--dev-python/wheezy-template/Manifest1
-rw-r--r--dev-python/wheezy-template/wheezy-template-3.1.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/wheezy-template/Manifest b/dev-python/wheezy-template/Manifest
new file mode 100644
index 000000000..adbbef0ea
--- /dev/null
+++ b/dev-python/wheezy-template/Manifest
@@ -0,0 +1 @@
+DIST wheezy.template-3.1.0.gh.tar.gz 66965 BLAKE2B 6cbaa6e5656a0b3bf417ed500770c97f2207f97822ccdf624c87cb0f3c0d2fa3b1a2269641325c6d6138568aeff3bcc417e6e4896186e2fe7c1b31a15e2d7365 SHA512 f73bb03c6c4d1d34f493ea4e97014a2bd2e14eba3fde5f7fc84a05036a0fdce35ebf4b0ab2ba9ead2a6bec73c416c2f477e44281a437fe776abb009293e1eab3
diff --git a/dev-python/wheezy-template/wheezy-template-3.1.0.ebuild b/dev-python/wheezy-template/wheezy-template-3.1.0.ebuild
new file mode 100644
index 000000000..0c8e99bd4
--- /dev/null
+++ b/dev-python/wheezy-template/wheezy-template-3.1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Tests aren't passing with PEP517
+#DISTUTILS_USE_PEP517="setuptools"
+PYTHON_COMPAT=( python3_{8,9,10} )
+
+inherit distutils-r1
+
+MY_PN="wheezy.template"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="lightweight template library"
+HOMEPAGE="https://github.com/akornatskyy/wheezy.template"
+# as usual pypi doesn't contains tests
+SRC_URI="https://github.com/akornatskyy/wheezy.template/archive/refs/tags/${PV}.tar.gz -> ${MY_P}.gh.tar.gz"
+S="${WORKDIR}/${MY_P}"
+KEYWORDS="~amd64"
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest