aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authortastytea <gentoo@tastytea.de>2023-12-23 15:27:42 +0100
committertastytea <gentoo@tastytea.de>2023-12-23 15:27:42 +0100
commitc929856c4ee9ffa40832a0035fa393e710e7f435 (patch)
treefdd7e65c256a0cbb0e3d5537f48a19781b0109c7 /games-util
parentgui-apps/swaylock-effects: drop 1.6.2, 1.6.3, add 1.7.0.0 (diff)
downloadguru-c929856c4ee9ffa40832a0035fa393e710e7f435.tar.gz
guru-c929856c4ee9ffa40832a0035fa393e710e7f435.tar.bz2
guru-c929856c4ee9ffa40832a0035fa393e710e7f435.zip
games-util/legendary: add 0.20.34
Signed-off-by: tastytea <gentoo@tastytea.de>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/legendary/Manifest1
-rw-r--r--games-util/legendary/legendary-0.20.34.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/games-util/legendary/Manifest b/games-util/legendary/Manifest
index 09107eb1f..7a920032b 100644
--- a/games-util/legendary/Manifest
+++ b/games-util/legendary/Manifest
@@ -1,2 +1,3 @@
DIST legendary-0.20.32.tar.gz 145312 BLAKE2B a59e959ccdc5d7d652b28f9a64474ded7cdf5da5708c61cb76821650802129fe0e5deef47af40c0461ff725b828faa11ca357063f9668acc8a4cceadf34b162f SHA512 9c7b1e944648a0a3a2d228bad2fbf72881299e70409375e1fb4d04ea3ed48226fedc042efcb065463dd1aecb32c8d9656254e3bdd507b1aff5f5cf8ca8e99d56
DIST legendary-0.20.33.tar.gz 147629 BLAKE2B bb79c69d9348251a09c851791185cfe78feeddd94ea4673c142af11745b65dae3420645d38c979e3b578b572a1aab47b95d01b8165b1c94f220e84b050ef15f8 SHA512 b81119820fe7eaee53dfc0f3dbc60ece186d3a2442c2be0395e5d2e2dd11b0b0ccc2bcbf841fa7f1ce55230c5bc62de30331ad24a1f43bd8a24d221fa3aa48a8
+DIST legendary-0.20.34.tar.gz 148218 BLAKE2B d68e14b17024d389f382238be3482436f2b8fdc64f6500c81bd0c400fc9348ff287dd407dc60cda5c880c830b87b5d436c37a9e3319ef5f29621f00b7109e6d7 SHA512 37ad1f7478d85fe38708acce76cb933c85bd2fb342fc8367423e3eb0d314fc85cea7ff2ae48385d507ba3bc7085f813efed257ac2aa95637b4dbc1a0aec57af8
diff --git a/games-util/legendary/legendary-0.20.34.ebuild b/games-util/legendary/legendary-0.20.34.ebuild
new file mode 100644
index 000000000..f9ba96a48
--- /dev/null
+++ b/games-util/legendary/legendary-0.20.34.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_SINGLE_IMPL=1
+inherit distutils-r1
+
+DESCRIPTION="A free and open-source replacement for the Epic Games Launcher"
+HOMEPAGE="https://github.com/derrod/legendary"
+SRC_URI="https://github.com/derrod/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="webview"
+
+# NOTE: dev-python/pywebview[qt5] is not much tested and does not function
+# correctly in some cases, according to release notes for 0.20.16.
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/filelock[${PYTHON_USEDEP}]
+ <dev-python/requests-3.0[${PYTHON_USEDEP}]
+ webview? ( dev-python/pywebview[gtk,${PYTHON_USEDEP}] )
+ ')
+"
+DEPEND="${RDEPEND}"