aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/rankstr/rankstr-0.1.0.ebuild')
-rw-r--r--sys-cluster/rankstr/rankstr-0.1.0.ebuild30
1 files changed, 0 insertions, 30 deletions
diff --git a/sys-cluster/rankstr/rankstr-0.1.0.ebuild b/sys-cluster/rankstr/rankstr-0.1.0.ebuild
deleted file mode 100644
index 2daa65413..000000000
--- a/sys-cluster/rankstr/rankstr-0.1.0.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="Split an MPI communicator into subcomms based on string values"
-HOMEPAGE="https://github.com/ECP-VeloC/rankstr"
-SRC_URI="https://github.com/ECP-VeloC/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-
-RDEPEND="virtual/mpi"
-DEPEND="${RDEPEND}"
-
-PATCHES=( "${FILESDIR}/${P}-no-static.patch" )
-RESTRICT="!test? ( test )"
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_SHARED_LIBS=ON
- -DENABLE_TESTS=$(usex test)
- -DRANKSTR_LINK_STATIC=OFF
- )
- cmake_src_configure
-}