summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-15 05:43:53 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-15 05:47:51 +0200
commit5770c94684ef7345b12a0d64b04149b9aa3ac31a (patch)
tree75a7adba6d6fb859d84034b6753e2fbc01d514b4
parentdev-python/simplejson: Bump to 3.19.3 (diff)
downloadgentoo-5770c94684ef7345b12a0d64b04149b9aa3ac31a.tar.gz
gentoo-5770c94684ef7345b12a0d64b04149b9aa3ac31a.tar.bz2
gentoo-5770c94684ef7345b12a0d64b04149b9aa3ac31a.zip
dev-python/webob: Bump to 1.8.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/webob/Manifest1
-rw-r--r--dev-python/webob/webob-1.8.8.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/webob/Manifest b/dev-python/webob/Manifest
index 782186a59389..001d41850f33 100644
--- a/dev-python/webob/Manifest
+++ b/dev-python/webob/Manifest
@@ -1 +1,2 @@
DIST WebOb-1.8.7.tar.gz 278544 BLAKE2B 20d8b00f181f2966b918f106080907746dac33b64e75c31749bd774709ed8aa51024258240b89abddacb041073705410845993f93ecfa4b98a7a0fcb8a14e505 SHA512 ff6a1ce796a59d9c078dc908a0d6307a080230a5c806be2278eebcbb78016bed43067e78e3e4a6d72a5f51184c137e8267ac75cbb92b057db008b51a792ff489
+DIST webob-1.8.8.tar.gz 279035 BLAKE2B 61bbcc71763feccbd7a39b2649024c8d7a49ab5602fd638b4a895900395cd54bb6b0885e0bdeccd6504f5cc3162f7e198e94016b98836dbed4ed608605251052 SHA512 13093e77591a3bdb36e8f30a5d40922120d949faf24e3322b0116f1a14483180772b22c82237b0db4a17a914c2c99509847a9f2a717de09b4bffa55fa5269838
diff --git a/dev-python/webob/webob-1.8.8.ebuild b/dev-python/webob/webob-1.8.8.ebuild
new file mode 100644
index 000000000000..57a32760f198
--- /dev/null
+++ b/dev-python/webob/webob-1.8.8.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_PN="WebOb"
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="WSGI request and response object"
+HOMEPAGE="
+ https://webob.org/
+ https://github.com/Pylons/webob/
+ https://pypi.org/project/WebOb/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/legacy-cgi[${PYTHON_USEDEP}]
+ ' 3.13)
+"
+
+distutils_enable_sphinx docs 'dev-python/alabaster'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # py3.9
+ sed -i -e 's:isAlive:is_alive:' tests/conftest.py || die
+ distutils-r1_src_prepare
+}