summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-08-19 02:16:21 +0100
committerSam James <sam@gentoo.org>2024-08-19 02:17:19 +0100
commit6772974ec4b3250f18dfaf2c142c8d439335e4a3 (patch)
treeaec388c4922aaec36de836f6e63a21d196467b3f
parentdev-go/go-tools: Compile go packages selectively (diff)
downloadgentoo-6772974ec4b3250f18dfaf2c142c8d439335e4a3.tar.gz
gentoo-6772974ec4b3250f18dfaf2c142c8d439335e4a3.tar.bz2
gentoo-6772974ec4b3250f18dfaf2c142c8d439335e4a3.zip
media-libs/xvid: disable assembly
There's a handful of very old asm impls in here for mmx+sse2 but they're non-PIC and unlikely to be worth it these days. Bug: https://bugs.gentoo.org/421841 Bug: https://bugs.gentoo.org/831044 Bug: https://bugs.gentoo.org/858431 Closes: https://bugs.gentoo.org/258804 Closes: https://bugs.gentoo.org/926543 Closes: https://bugs.gentoo.org/937019 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-libs/xvid/xvid-1.3.7-r2.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/media-libs/xvid/xvid-1.3.7-r2.ebuild b/media-libs/xvid/xvid-1.3.7-r2.ebuild
new file mode 100644
index 000000000000..426740f1a060
--- /dev/null
+++ b/media-libs/xvid/xvid-1.3.7-r2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="${PN}core"
+MY_P="${MY_PN}-${PV}"
+inherit flag-o-matic multilib-minimal
+
+DESCRIPTION="High performance/quality MPEG-4 video de-/encoding solution"
+HOMEPAGE="https://www.xvid.org/"
+SRC_URI="https://downloads.xvid.com/downloads/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_PN}/build/generic"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="examples"
+
+NASM=">=dev-lang/nasm-2"
+YASM=">=dev-lang/yasm-1"
+
+BDEPEND="sys-apps/grep"
+DEPEND="
+ amd64? ( || ( ${YASM} ${NASM} ) )
+ x86? ( || ( ${YASM} ${NASM} ) )
+ x64-macos? ( ${NASM} )
+"
+
+src_prepare() {
+ default
+
+ # make build verbose
+ sed \
+ -e 's/@$(CC)/$(CC)/' \
+ -e 's/@$(AS)/$(AS)/' \
+ -e 's/@$(RM)/$(RM)/' \
+ -e 's/@$(INSTALL)/$(INSTALL)/' \
+ -e 's/@cd/cd/' \
+ -e '/\$(libdir)\/\$(STATIC_LIB)/d' \
+ -e 's/\$(BUILD_DIR)\/\$(STATIC_LIB)//g' \
+ -e 's/info \$(STATIC_LIB)/info/g' \
+ -i Makefile || die
+ # Since only the build system is in $S, this will only copy it but not the
+ # entire sources.
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ use sparc && append-cflags -mno-vis #357149
+
+ local myconf=(
+ --enable-pthread
+ # On x86, only available for mmx+sse2 and non-PIC.
+ # Not worth it.
+ --disable-assembly
+ )
+
+ econf "${myconf[@]}"
+}
+
+multilib_src_install_all() {
+ dodoc "${S}"/../../{AUTHORS,ChangeLog*,CodingStyle,README,TODO}
+
+ if use examples; then
+ insinto /usr/share/${PN}
+ doins -r "${S}"/../../examples
+ fi
+}