summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-08-18 20:56:04 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-08-18 20:56:30 +0300
commit6776b73f09edd4c2004c774f857e69b797ecd124 (patch)
tree219ba80a065cfff18ba23a61f0431b936c0f1c64
parentdev-ml/mccs: Stabilize 1.1.17 ppc64, #938140 (diff)
downloadgentoo-6776b73f09edd4c2004c774f857e69b797ecd124.tar.gz
gentoo-6776b73f09edd4c2004c774f857e69b797ecd124.tar.bz2
gentoo-6776b73f09edd4c2004c774f857e69b797ecd124.zip
app-vim/vimtex: add 2.15
Closes: https://bugs.gentoo.org/905130 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--app-vim/vimtex/Manifest1
-rw-r--r--app-vim/vimtex/vimtex-2.15.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/app-vim/vimtex/Manifest b/app-vim/vimtex/Manifest
index e092e8ba30de..4f1a20cbff10 100644
--- a/app-vim/vimtex/Manifest
+++ b/app-vim/vimtex/Manifest
@@ -1 +1,2 @@
DIST vimtex-1.5.tar.gz 1666938 BLAKE2B 7d203f25b1f5c653bb270fb4cb5463d2851fe63d52dde9b99d8ca4e2c7936f7291c649e5a71d25c01329a2caf3aa4258f302d2585c6b7e67991e5f91dd785526 SHA512 9009a830e117c8d1d6b00f97cb1382704c77120e05810ad40d1ec191cb547e5045101d2901b88d85b42d17ba51cdd5f5a00b2f80aa2424e2529bb19c7f651f00
+DIST vimtex-2.15.tar.gz 1092207 BLAKE2B 19feb79c47fa7906fbf97c126ca30a3ff89cd2b5aa034356e48d202eb55f41320bce1d40011dee4f8d099678a9748405ad7913f6df520773050fe494402f56e6 SHA512 1e436a375d3244b2bd3ccd82badc31f145c95990c1b058b5aa02ecb1adaafc80c6bf31661229fe6cb4f262c282da49755491b7311c0d450e5782d427e92ada1e
diff --git a/app-vim/vimtex/vimtex-2.15.ebuild b/app-vim/vimtex/vimtex-2.15.ebuild
new file mode 100644
index 000000000000..a79ca01e84a6
--- /dev/null
+++ b/app-vim/vimtex/vimtex-2.15.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: a modern vim plugin for editing LaTeX files"
+HOMEPAGE="https://github.com/lervag/vimtex"
+SRC_URI="https://github.com/lervag/vimtex/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+RDEPEND="
+ !app-vim/vim-latex
+ !app-vim/automatictexplugin
+"
+
+src_install() {
+ vim-plugin_src_install lua
+}