summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2023-06-27 02:31:52 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2023-06-27 02:31:52 +0000
commit7e589a7cdb592f501df2eb02b143c9ef61db18df (patch)
treedf6e6b7ca606f1dc7a4f69a1c36c5f1306161974
parent2023-06-27 01:46:58 UTC (diff)
parentapp-shells/starship: Stabilize 1.14.2 amd64, #909208 (diff)
downloadgentoo-7e589a7cdb592f501df2eb02b143c9ef61db18df.tar.gz
gentoo-7e589a7cdb592f501df2eb02b143c9ef61db18df.tar.bz2
gentoo-7e589a7cdb592f501df2eb02b143c9ef61db18df.zip
Merge updates from master
-rw-r--r--app-shells/starship/starship-1.14.2.ebuild2
-rw-r--r--net-misc/spice-gtk/files/spice-gtk-0.42-libtool-export-symbols-fix.patch66
-rw-r--r--net-misc/spice-gtk/spice-gtk-0.42-r3.ebuild (renamed from net-misc/spice-gtk/spice-gtk-0.42-r2.ebuild)4
-rw-r--r--sys-apps/iproute2/Manifest1
-rw-r--r--sys-apps/iproute2/iproute2-6.4.0.ebuild219
5 files changed, 291 insertions, 1 deletions
diff --git a/app-shells/starship/starship-1.14.2.ebuild b/app-shells/starship/starship-1.14.2.ebuild
index ae7fab55cea6..42462a85da6c 100644
--- a/app-shells/starship/starship-1.14.2.ebuild
+++ b/app-shells/starship/starship-1.14.2.ebuild
@@ -394,7 +394,7 @@ SRC_URI="
LICENSE="0BSD Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD BSD-2 Boost-1.0 CC0-1.0 ISC MIT MIT-0 MPL-2.0 Unicode-DFS-2016 Unlicense WTFPL-2 ZLIB"
SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="amd64"
BDEPEND="dev-util/cmake
>=virtual/rust-1.65"
diff --git a/net-misc/spice-gtk/files/spice-gtk-0.42-libtool-export-symbols-fix.patch b/net-misc/spice-gtk/files/spice-gtk-0.42-libtool-export-symbols-fix.patch
new file mode 100644
index 000000000000..1af5ba26790f
--- /dev/null
+++ b/net-misc/spice-gtk/files/spice-gtk-0.42-libtool-export-symbols-fix.patch
@@ -0,0 +1,66 @@
+Bug: https://bugs.gentoo.org/902853
+Bug: https://bugs.gentoo.org/888705
+Upstream: https://gitlab.freedesktop.org/spice/spice-gtk/-/merge_requests/119
+Upstream Bug: https://gitlab.freedesktop.org/spice/spice-gtk/-/issues/169
+
+From 1511f0ad5ea67b4657540c631e3a8c959bb8d578 Mon Sep 17 00:00:00 2001
+From: Frediano Ziglio <freddy77@gmail.com>
+Date: Wed, 21 Jun 2023 18:43:59 +0100
+Subject: [PATCH] Do not use libtool -export-symbols option
+
+This option is intended for libtool, not for any linker.
+Check the support of --version-script option using an empty
+list of symbols to catch some faulty linker supporting that
+option but not allowing not existing symbols (some buggy mold
+versions).
+
+Signed-off-by: Frediano Ziglio <freddy77@gmail.com>
+--- a/src/meson.build
++++ b/src/meson.build
+@@ -181,14 +181,19 @@ endif
+ #
+
+ # version-script
++test_syms_path = meson.current_source_dir() / 'test-map-file'
++test_version_script = '-Wl,--version-script=@0@'.format(test_syms_path)
++spice_has_version_script = compiler.has_link_argument(test_version_script)
++
+ spice_client_glib_syms = files('map-file')
+ spice_client_glib_syms_path = meson.current_source_dir() / 'map-file'
+ spice_gtk_version_script = '-Wl,--version-script=@0@'.format(spice_client_glib_syms_path)
+-spice_gtk_has_version_script = compiler.has_link_argument(spice_gtk_version_script)
+-if not spice_gtk_has_version_script
+- spice_client_glib_syms = files('spice-glib-sym-file')
+- spice_client_glib_syms_path = meson.current_source_dir() / 'spice-glib-sym-file'
+- spice_gtk_version_script = ['-export-symbols', spice_client_glib_syms_path]
++if not spice_has_version_script
++ if host_machine.system() == 'linux'
++ error('Version scripts should be supported on Linux')
++ endif
++ spice_client_glib_syms = []
++ spice_gtk_version_script = []
+ endif
+
+ # soversion
+@@ -373,11 +378,6 @@ if spice_gtk_has_gtk
+ # libspice-client-gtk.so
+ #
+ spice_client_gtk_syms = spice_client_glib_syms
+- if not spice_gtk_has_version_script
+- spice_client_gtk_syms = files('spice-gtk-sym-file')
+- spice_client_gtk_syms_path = meson.current_source_dir() / 'spice-gtk-sym-file'
+- spice_gtk_version_script = ['-export-symbols', spice_client_gtk_syms_path]
+- endif
+
+ # soversion
+ # http://www.gnu.org/software/libtool/manual/html_node/Updating-version-info.html
+--- /dev/null
++++ b/src/test-map-file
+@@ -0,0 +1,4 @@
++TEST_LIB {
++local:
++*;
++};
+--
+GitLab
+
diff --git a/net-misc/spice-gtk/spice-gtk-0.42-r2.ebuild b/net-misc/spice-gtk/spice-gtk-0.42-r3.ebuild
index fe18fb9f4736..83318d830e49 100644
--- a/net-misc/spice-gtk/spice-gtk-0.42-r2.ebuild
+++ b/net-misc/spice-gtk/spice-gtk-0.42-r3.ebuild
@@ -89,6 +89,10 @@ BDEPEND="
vala? ( $(vala_depend) )
"
+PATCHES=(
+ "${FILESDIR}/${PN}-0.42-libtool-export-symbols-fix.patch"
+)
+
python_check_deps() {
python_has_version "dev-python/six[${PYTHON_USEDEP}]" &&
python_has_version "dev-python/pyparsing[${PYTHON_USEDEP}]"
diff --git a/sys-apps/iproute2/Manifest b/sys-apps/iproute2/Manifest
index 36392cb55060..d4f10b35a52f 100644
--- a/sys-apps/iproute2/Manifest
+++ b/sys-apps/iproute2/Manifest
@@ -3,3 +3,4 @@ DIST iproute2-6.0.0.tar.xz 900312 BLAKE2B 1cfb9b5a7892dec2b35e0eadbd957083e95fdc
DIST iproute2-6.1.0.tar.xz 905512 BLAKE2B 38249703e0a9ba74405aebdb97560b286deefa959a9c3f0e0893962b6966f5da2da46199dda6a0f9584bb473f8ba529440643d97f66e9b7619df029e3091d163 SHA512 4e4d3b5e1e1a5444f42671c1e6caee072e80063e34e37386695f76f85a1ab662f4513050814006e5154426cbaadfba1d86b0be14e65978d5e670a16446047b28
DIST iproute2-6.2.0.tar.xz 911588 BLAKE2B d3bfaecf33ffc7861e983e8db0d6a63f4767b6c01b5346e88f51c65ed6279c4be29412ed18b8f98ed54d60a84455b73fe7745142fd0fc0f3e327a29e8bcce986 SHA512 b24e0fdd0f51b8b78bc3bb681e3829af47d3011e93f3892289eb070b336709a6883728ecc7627ca37f6449720f8ed1349af321c0d04454894a7175b82f7de151
DIST iproute2-6.3.0.tar.xz 914700 BLAKE2B a7b48c59c8a30f56ca810136f4d9f681fe38359999c260227a6229b972ce70b233d2865a6543cf3f70ed586825f9191c22d459a9fc5cc8c7dbf3ab417064c8a7 SHA512 aec1d8ceb54c8849a075ec1ce079678638e05ccaec093e8b3cbc7243b5fafea2a8c11f10930fced3df82f52d6750aa325178e44f9058e37a556ab108d4a968bf
+DIST iproute2-6.4.0.tar.xz 922164 BLAKE2B 76369d2a794afd13dba1a34ee9a7425775bb7b43c22164274749c01b18d061669aa5abd51d32a15d68f48e75f4837a887dfc28ea41e34d8e4c36b2ab865628dd SHA512 42330be6e061302694ea301765ff8d3cbfaeca4b1d06e39778861e4390ed211c03cb2d41498190202b659f7f5647b1ca4857410ef8c16fd601a35e7162788d21
diff --git a/sys-apps/iproute2/iproute2-6.4.0.ebuild b/sys-apps/iproute2/iproute2-6.4.0.ebuild
new file mode 100644
index 000000000000..5281e47ca76a
--- /dev/null
+++ b/sys-apps/iproute2/iproute2-6.4.0.ebuild
@@ -0,0 +1,219 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo toolchain-funcs
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://git.kernel.org/pub/scm/linux/kernel/git/shemminger/iproute2.git"
+ inherit git-r3
+else
+ SRC_URI="https://www.kernel.org/pub/linux/utils/net/${PN}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+DESCRIPTION="kernel routing and traffic control utilities"
+HOMEPAGE="https://wiki.linuxfoundation.org/networking/iproute2"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="atm berkdb bpf caps elf +iptables libbsd minimal nfs selinux split-usr"
+# Needs root
+RESTRICT="test"
+
+# We could make libmnl optional, but it's tiny, so eh
+RDEPEND="
+ !net-misc/arpd
+ !minimal? ( net-libs/libmnl:= )
+ atm? ( net-dialup/linux-atm )
+ berkdb? ( sys-libs/db:= )
+ bpf? ( dev-libs/libbpf:= )
+ caps? ( sys-libs/libcap )
+ elf? ( virtual/libelf:= )
+ iptables? ( >=net-firewall/iptables-1.4.20:= )
+ libbsd? ( dev-libs/libbsd )
+ nfs? ( net-libs/libtirpc:= )
+ selinux? ( sys-libs/libselinux )
+"
+# We require newer linux-headers for ipset support (bug #549948) and some defines (bug #553876)
+DEPEND="
+ ${RDEPEND}
+ >=sys-kernel/linux-headers-3.16
+"
+BDEPEND="
+ app-arch/xz-utils
+ >=sys-devel/bison-2.4
+ sys-devel/flex
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.1.0-mtu.patch # bug #291907
+ "${FILESDIR}"/${PN}-5.12.0-configure-nomagic.patch # bug #643722
+ "${FILESDIR}"/${PN}-5.7.0-mix-signal.h-include.patch
+)
+
+src_prepare() {
+ default
+
+ # Fix version if necessary
+ local versionfile="include/version.h"
+ if [[ ${PV} != 9999 ]] && ! grep -Fq "${PV}" ${versionfile} ; then
+ einfo "Fixing version string"
+ sed "s@\"[[:digit:]\.]\+\"@\"${PV}\"@" \
+ -i ${versionfile} || die
+ fi
+
+ # echo -n is not POSIX compliant
+ sed 's@echo -n@printf@' -i configure || die
+
+ sed -i \
+ -e '/^CC :\?=/d' \
+ -e "/^LIBDIR/s:=.*:=/$(get_libdir):" \
+ -e "s|-O2|${CFLAGS} ${CPPFLAGS}|" \
+ -e "/^HOSTCC/s:=.*:= $(tc-getBUILD_CC):" \
+ -e "/^DBM_INCLUDE/s:=.*:=${T}:" \
+ Makefile || die
+
+ # Build against system headers
+ rm -r include/netinet || die #include/linux include/ip{,6}tables{,_common}.h include/libiptc
+ sed -i 's:TCPI_OPT_ECN_SEEN:16:' misc/ss.c || die
+
+ if use minimal ; then
+ sed -i -e '/^SUBDIRS=/s:=.*:=lib tc ip:' Makefile || die
+ fi
+}
+
+src_configure() {
+ tc-export AR CC PKG_CONFIG
+
+ # This sure is ugly. Should probably move into toolchain-funcs at some point.
+ local setns
+ pushd "${T}" >/dev/null || die
+ printf '#include <sched.h>\nint main(){return setns(0, 0);}\n' > test.c || die
+ if ${CC} ${CFLAGS} ${CPPFLAGS} -D_GNU_SOURCE ${LDFLAGS} test.c >&/dev/null ; then
+ setns=y
+ else
+ setns=n
+ fi
+
+ echo 'int main(){return 0;}' > test.c || die
+ if ! ${CC} ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} test.c -lresolv >&/dev/null ; then
+ sed -i '/^LDLIBS/s:-lresolv::' "${S}"/Makefile || die
+ fi
+ popd >/dev/null || die
+
+ # run "configure" script first which will create "config.mk"...
+ # Using econf breaks since 5.14.0 (a9c3d70d902a0473ee5c13336317006a52ce8242)
+ edo ./configure --libbpf_force $(usex bpf on off)
+
+ # Remove the definitions made by configure and allow them to be overridden
+ # by USE flags below.
+ # We have to do the cheesy only-sed-if-disabled because otherwise
+ # the *_FLAGS etc stuff found by configure will be used but result
+ # in a broken build.
+ if ! use berkdb ; then
+ sed -i -e '/HAVE_BERKELEY_DB/d' config.mk || die
+ fi
+
+ if ! use caps ; then
+ sed -i -e '/HAVE_CAP/d' config.mk || die
+ fi
+
+ if use minimal ; then
+ sed -i -e '/HAVE_MNL/d' config.mk || die
+ fi
+
+ if ! use elf ; then
+ sed -i -e '/HAVE_ELF/d' config.mk || die
+ fi
+
+ if ! use nfs ; then
+ sed -i -e '/HAVE_RPC/d' config.mk || die
+ fi
+
+ if ! use selinux ; then
+ sed -i -e '/HAVE_SELINUX/d' config.mk || die
+ fi
+
+ if ! use libbsd ; then
+ sed -i -e '/HAVE_LIBBSD/d' config.mk || die
+ fi
+
+ # ...Now switch on/off requested features via USE flags
+ # this is only useful if the test did not set other things, per bug #643722
+ # Keep in sync with ifs above, or refactor to be unified.
+ cat <<-EOF >> config.mk
+ TC_CONFIG_ATM := $(usex atm y n)
+ TC_CONFIG_XT := $(usex iptables y n)
+ TC_CONFIG_NO_XT := $(usex iptables n y)
+ # We've locked in recent enough kernel headers, bug #549948
+ TC_CONFIG_IPSET := y
+ HAVE_BERKELEY_DB := $(usex berkdb y n)
+ HAVE_CAP := $(usex caps y n)
+ HAVE_MNL := $(usex minimal n y)
+ HAVE_ELF := $(usex elf y n)
+ HAVE_RPC := $(usex nfs y n)
+ HAVE_SELINUX := $(usex selinux y n)
+ IP_CONFIG_SETNS := ${setns}
+ # Use correct iptables dir, bug #144265, bug #293709
+ IPT_LIB_DIR := $(use iptables && ${PKG_CONFIG} xtables --variable=xtlibdir)
+ HAVE_LIBBSD := $(usex libbsd y n)
+ EOF
+}
+
+src_compile() {
+ emake V=1 NETNS_RUN_DIR=/run/netns
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ if use minimal ; then
+ into /
+ dosbin tc/tc
+ dobin ip/ip
+ return 0
+ fi
+
+ emake \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}/usr" \
+ LIBDIR="${EPREFIX}"/$(get_libdir) \
+ SBINDIR="${EPREFIX}"/sbin \
+ CONFDIR="${EPREFIX}"/etc/iproute2 \
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+ MANDIR="${EPREFIX}"/usr/share/man \
+ ARPDDIR="${EPREFIX}"/var/lib/arpd \
+ install
+
+ dodir /bin
+ mv "${ED}"/{s,}bin/ip || die # bug #330115
+
+ dolib.a lib/libnetlink.a
+ insinto /usr/include
+ doins include/libnetlink.h
+
+ # Collides with net-analyzer/ifstat
+ # https://bugs.gentoo.org/868321
+ mv "${ED}"/sbin/ifstat{,-iproute2} || die
+
+ if use split-usr ; then
+ # Can remove compatibility symlink in a year: 2023-05-28.
+ # bug #547264
+ mv "${ED}"/sbin/ss "${ED}"/bin/ss || die
+ dosym -r /bin/ss /sbin/ss
+ fi
+
+ if use berkdb ; then
+ keepdir /var/lib/arpd
+ # bug #47482, arpd doesn't need to be in /sbin
+ dodir /usr/bin
+ mv "${ED}"/sbin/arpd "${ED}"/usr/bin/ || die
+ elif [[ -d "${ED}"/var/lib/arpd ]]; then
+ rmdir --ignore-fail-on-non-empty -p "${ED}"/var/lib/arpd || die
+ fi
+}