summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2023-01-16 08:02:14 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2023-01-16 08:02:14 +0000
commit968977e3ba875dcd60f600a2a4df2a850faf7397 (patch)
tree82ad2b8647da4ba1c33917f7324d4b8a441ead86
parent2023-01-16 07:47:17 UTC (diff)
parentdev-tcltk/snack: fix parallelMake (diff)
downloadgentoo-968977e3ba875dcd60f600a2a4df2a850faf7397.tar.gz
gentoo-968977e3ba875dcd60f600a2a4df2a850faf7397.tar.bz2
gentoo-968977e3ba875dcd60f600a2a4df2a850faf7397.zip
Merge updates from master
-rw-r--r--dev-tcltk/snack/files/snack-2.2.10-parallelMake.patch20
-rw-r--r--dev-tcltk/snack/snack-2.2.10-r11.ebuild1
-rw-r--r--www-servers/tomcat/tomcat-9.0.71-r1.ebuild (renamed from www-servers/tomcat/tomcat-9.0.71.ebuild)2
3 files changed, 22 insertions, 1 deletions
diff --git a/dev-tcltk/snack/files/snack-2.2.10-parallelMake.patch b/dev-tcltk/snack/files/snack-2.2.10-parallelMake.patch
new file mode 100644
index 000000000000..53e79c0f1eff
--- /dev/null
+++ b/dev-tcltk/snack/files/snack-2.2.10-parallelMake.patch
@@ -0,0 +1,20 @@
+--- a/unix/Makefile.in 2023-01-16 08:39:23.021056229 +0100
++++ b/unix/Makefile.in 2023-01-16 08:40:31.485926112 +0100
+@@ -290,7 +290,7 @@
+ SphereFile.o: $(GENERIC_DIR)/SphereFile.c
+ $(CC) -c $(CFLAGS) -DUSE_SNACK_STUBS $(GENERIC_DIR)/SphereFile.c
+
+-libsnacksphere${SHLIB_SUFFIX}: ${OBJNIST}
++libsnacksphere${SHLIB_SUFFIX}: ${OBJNIST} stublib
+ ${SHLIB_LD} ${OBJNIST} ${LIBNIST} -o libsnacksphere${SHLIB_SUFFIX}
+
+ LIBOGG = @OGGLIBS@ -lc @TCL_LIB_SPEC@ -L. @SNACK_STUB_LIB_FLAG@
+@@ -299,7 +299,7 @@
+ SnackOgg.o: $(GENERIC_DIR)/SnackOgg.c
+ $(CC) @OGGINC@ -c $(CFLAGS) -DUSE_SNACK_STUBS $(GENERIC_DIR)/SnackOgg.c
+
+-libsnackogg${SHLIB_SUFFIX}: ${OBJOGG}
++libsnackogg${SHLIB_SUFFIX}: ${OBJOGG} stublib
+ ${SHLIB_LD} ${OBJOGG} ${LIBOGG} -o libsnackogg${SHLIB_SUFFIX}
+
+ install:
diff --git a/dev-tcltk/snack/snack-2.2.10-r11.ebuild b/dev-tcltk/snack/snack-2.2.10-r11.ebuild
index 6d62f7387c2b..86a34a7ced5e 100644
--- a/dev-tcltk/snack/snack-2.2.10-r11.ebuild
+++ b/dev-tcltk/snack/snack-2.2.10-r11.ebuild
@@ -45,6 +45,7 @@ PATCHES=(
"${FILESDIR}"/${P}-lto.patch
"${FILESDIR}"/${P}-configure-clang16.patch
"${FILESDIR}"/${P}-implicit.patch
+ "${FILESDIR}"/${P}-parallelMake.patch
)
HTML_DOCS="${WORKDIR}/${PN}${PV}/doc/*"
diff --git a/www-servers/tomcat/tomcat-9.0.71.ebuild b/www-servers/tomcat/tomcat-9.0.71-r1.ebuild
index d9ebbde0ef2d..59476cacba78 100644
--- a/www-servers/tomcat/tomcat-9.0.71.ebuild
+++ b/www-servers/tomcat/tomcat-9.0.71-r1.ebuild
@@ -32,7 +32,7 @@ RESTRICT="test" # can we run them on a production system?
# though it could work with 4.22 and upstream uses 4.20,
# we still use 4.15 because 4.20+ is currently built with java 11
# and it would force Tomcat to use at least java 11 too
-ECJ_SLOT="4.26"
+ECJ_SLOT="4.15"
SERVLET_API_SLOT="4.0"
JSP_API_SLOT="2.3"
EL_API_SLOT="3.0"