summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2021-06-20 16:50:07 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2021-06-20 16:50:07 +0000
commita0e22c27cc37662ee4209b7415ea91f3c0779a93 (patch)
tree24c3b4bf1d0068e54d80c7896a495b770bf2dfd6
parent2021-06-20 16:35:10 UTC (diff)
parentdev-perl/IO-AIO: Version bump 4.75 (diff)
downloadgentoo-a0e22c27cc37662ee4209b7415ea91f3c0779a93.tar.gz
gentoo-a0e22c27cc37662ee4209b7415ea91f3c0779a93.tar.bz2
gentoo-a0e22c27cc37662ee4209b7415ea91f3c0779a93.zip
Merge updates from master
-rw-r--r--dev-perl/IO-AIO/IO-AIO-4.750.0.ebuild30
-rw-r--r--dev-perl/IO-AIO/Manifest1
-rw-r--r--dev-perl/Inline-Files/Inline-Files-0.710.0.ebuild20
-rw-r--r--dev-perl/Inline-Files/Manifest1
-rw-r--r--dev-python/matplotlib/matplotlib-3.4.2.ebuild10
-rw-r--r--dev-python/pygobject/files/pygobject-3.40.1-dynamicimporter-py310.patch63
-rw-r--r--dev-python/pygobject/pygobject-3.40.1-r1.ebuild78
-rw-r--r--eclass/perl-module.eclass41
8 files changed, 238 insertions, 6 deletions
diff --git a/dev-perl/IO-AIO/IO-AIO-4.750.0.ebuild b/dev-perl/IO-AIO/IO-AIO-4.750.0.ebuild
new file mode 100644
index 000000000000..8547c08f08d9
--- /dev/null
+++ b/dev-perl/IO-AIO/IO-AIO-4.750.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=MLEHMANN
+DIST_VERSION=4.75
+DIST_WIKI="tests"
+inherit perl-module
+
+DESCRIPTION="Asynchronous Input/Output"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ dev-perl/common-sense
+"
+BDEPEND="${RDEPEND}
+ >=dev-perl/Canary-Stability-2001
+ >=virtual/perl-ExtUtils-MakeMaker-6.520.0
+"
+
+src_test() {
+ if [[ "${IO_AIO_SANDBOX_TESTS:-0}" == 0 ]]; then
+ # Tests trigger stack overflow in sandbox code, see bug 553918
+ perl_rm_files t/01_stat.t t/02_read.t t/05_readdir.t t/03_errors.t
+ fi
+ perl-module_src_test
+}
diff --git a/dev-perl/IO-AIO/Manifest b/dev-perl/IO-AIO/Manifest
index 0088c88b8dec..812a15689086 100644
--- a/dev-perl/IO-AIO/Manifest
+++ b/dev-perl/IO-AIO/Manifest
@@ -1 +1,2 @@
DIST IO-AIO-4.34.tar.gz 156615 BLAKE2B 913e90403bc8172d2376420c3cc3c48e4d694580a71adfa19e59e8f0c7d8d451df736686393423b94f2f916002c153ddae40a1350d05ae20f035f633e8df9c50 SHA512 7b7e05fb01513864321c1aa2a28192444299486831b75461bd57bad5a0370863d46df42c698288096eac55f9972a3492f8af46cb265f13c721da698c9fe3529c
+DIST IO-AIO-4.75.tar.gz 181557 BLAKE2B 842b15d19607eff47bdaee7afd4b823d6333e31a9cc8b5eaf4ad875103b2e37adfb7f1cfbdc1cecc99d4b1375f29101087f26d6e1f85fbf8e026b5985d46ac62 SHA512 3a30b34d6de476accc9b07c0723a3b21c235e5bd2b5951edc3ce3150de22a6b7dab5634d78ec17b799a71f2ede0bc138fead1e02885eed31a4da5cec05dfcaa3
diff --git a/dev-perl/Inline-Files/Inline-Files-0.710.0.ebuild b/dev-perl/Inline-Files/Inline-Files-0.710.0.ebuild
new file mode 100644
index 000000000000..2f594711d7a5
--- /dev/null
+++ b/dev-perl/Inline-Files/Inline-Files-0.710.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=AMBS
+DIST_VERSION=0.71
+inherit perl-module
+
+DESCRIPTION="Multiple virtual files in a single file"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+RESTRICT="!test? ( test )"
+
+RDEPEND=""
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( virtual/perl-Test )
+"
diff --git a/dev-perl/Inline-Files/Manifest b/dev-perl/Inline-Files/Manifest
index b01fe91eeec3..b13d0b4317fc 100644
--- a/dev-perl/Inline-Files/Manifest
+++ b/dev-perl/Inline-Files/Manifest
@@ -1 +1,2 @@
DIST Inline-Files-0.69.tar.gz 14804 BLAKE2B 2f2f49b8832ebb8f8e7ac9567c7fdddfe742297c96095061f6daf2098f35e0ad28fd23a8c84b6f1fed7d7cf9337aca2282e8d614e54145c361e2494e828539fd SHA512 87b3d837a6d30eb344e7c80f866297558d3f1f8275d1e9fac0b9a1adfbee83f8452f686dcd39ce7c48bda50f1442b194822ee194da84464d076d2ac629ff289e
+DIST Inline-Files-0.71.tar.gz 15333 BLAKE2B c2bac14a9bac83d3272818b17d92a45372de79983254b42be3ad1c0417b88f2a6ef24c156659362b3c4eccdfd500515290e4cfef5d8e8e7e65c65f0288d96eac SHA512 19497c6f8d56158fa3165edc791ea6e1203be988687ebc068b235e7e71b9a99f15663d4923ef69854b6954141b53fbb524a02f55b66577c29a2c65a23ea15519
diff --git a/dev-python/matplotlib/matplotlib-3.4.2.ebuild b/dev-python/matplotlib/matplotlib-3.4.2.ebuild
index 54f4fde613b6..2bc085e89cfb 100644
--- a/dev-python/matplotlib/matplotlib-3.4.2.ebuild
+++ b/dev-python/matplotlib/matplotlib-3.4.2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE='tk?,threads(+)'
inherit distutils-r1 flag-o-matic virtualx toolchain-funcs prefix
@@ -50,7 +50,7 @@ RDEPEND="
dev-python/xlwt[${PYTHON_USEDEP}]
)
gtk3? (
- dev-python/pygobject:3[cairo?,${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.40.1-r1:3[cairo?,${PYTHON_USEDEP}]
x11-libs/gtk+:3[introspection]
)
latex? (
@@ -69,7 +69,9 @@ RDEPEND="
>=www-servers/tornado-6.0.4[${PYTHON_USEDEP}]
)
wxwidgets? (
- dev-python/wxpython:*[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/wxpython:*[${PYTHON_USEDEP}]
+ ' python3_{8,9})
)
"
@@ -93,7 +95,7 @@ BDEPEND="
test? (
dev-python/flaky[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pygobject:3[cairo?,${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.40.1-r1:3[cairo?,${PYTHON_USEDEP}]
>=www-servers/tornado-6.0.4[${PYTHON_USEDEP}]
x11-libs/gtk+:3[introspection]
)
diff --git a/dev-python/pygobject/files/pygobject-3.40.1-dynamicimporter-py310.patch b/dev-python/pygobject/files/pygobject-3.40.1-dynamicimporter-py310.patch
new file mode 100644
index 000000000000..341a096767b6
--- /dev/null
+++ b/dev-python/pygobject/files/pygobject-3.40.1-dynamicimporter-py310.patch
@@ -0,0 +1,63 @@
+From 1ae65be0f7e621002e2e29921e0252c1b57a170c Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Sun, 20 Jun 2021 17:54:52 +0200
+Subject: [PATCH] Implement PEP451 semantics for DynamicImporter
+
+Make DynamicImporter PEP451-compliant in order to silence ImportWarnings
+in Python 3.10. This is mostly based on six._SixMetaPathImporter.
+
+Fixes #476
+---
+ gi/importer.py | 18 ++++++++++++++++++
+ 1 file changed, 18 insertions(+)
+
+diff --git a/gi/importer.py b/gi/importer.py
+index 32967974..006cf464 100644
+--- a/gi/importer.py
++++ b/gi/importer.py
+@@ -24,6 +24,7 @@
+ import sys
+ import warnings
+ import importlib
++import importlib.util
+ from contextlib import contextmanager
+
+ import gi
+@@ -103,6 +104,7 @@ def get_import_stacklevel(import_hook):
+ class DynamicImporter(object):
+
+ # Note: see PEP302 for the Importer Protocol implemented below.
++ # PEP451 for A ModuleSpec Type for the Import System.
+
+ def __init__(self, path):
+ self.path = path
+@@ -117,6 +119,16 @@ class DynamicImporter(object):
+
+ return self
+
++ def find_spec(self, fullname, path, target=None):
++ if not fullname.startswith(self.path):
++ return None
++
++ path, namespace = fullname.rsplit('.', 1)
++ if path != self.path:
++ return None
++
++ return importlib.util.spec_from_loader(fullname, self)
++
+ def load_module(self, fullname):
+ if fullname in sys.modules:
+ return sys.modules[fullname]
+@@ -149,3 +161,9 @@ class DynamicImporter(object):
+ sys.modules[fullname] = dynamic_module
+
+ return dynamic_module
++
++ def create_module(self, spec):
++ return self.load_module(spec.name)
++
++ def exec_module(self, module):
++ pass
+--
+2.32.0
+
diff --git a/dev-python/pygobject/pygobject-3.40.1-r1.ebuild b/dev-python/pygobject/pygobject-3.40.1-r1.ebuild
new file mode 100644
index 000000000000..01f7b7055ebd
--- /dev/null
+++ b/dev-python/pygobject/pygobject-3.40.1-r1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit gnome.org meson python-r1 virtualx xdg
+
+DESCRIPTION="Python bindings for GObject Introspection"
+HOMEPAGE="https://pygobject.readthedocs.io/"
+
+LICENSE="LGPL-2.1+"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="+cairo examples test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.56:2
+ >=dev-libs/gobject-introspection-1.56:=
+ dev-libs/libffi:=
+ cairo? (
+ >=dev-python/pycairo-1.16.0[${PYTHON_USEDEP}]
+ x11-libs/cairo[glib] )
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-libs/atk[introspection]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ x11-libs/gdk-pixbuf:2[introspection,jpeg]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection]
+ )
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-dynamicimporter-py310.patch
+)
+
+src_configure() {
+ configuring() {
+ meson_src_configure \
+ $(meson_feature cairo pycairo) \
+ $(meson_use test tests) \
+ -Dpython="${EPYTHON}"
+ }
+
+ python_foreach_impl configuring
+}
+
+src_compile() {
+ python_foreach_impl meson_src_compile
+}
+
+src_test() {
+ local -x GIO_USE_VFS="local" # prevents odd issues with deleting ${T}/.gvfs
+ local -x GIO_USE_VOLUME_MONITOR="unix" # prevent udisks-related failures in chroots, bug #449484
+
+ testing() {
+ local -x XDG_CACHE_HOME="${T}/${EPYTHON}"
+ meson_src_test || die "test failed for ${EPYTHON}"
+ }
+ virtx python_foreach_impl testing
+}
+
+src_install() {
+ installing() {
+ meson_src_install
+ python_optimize
+ }
+ python_foreach_impl installing
+ use examples && dodoc -r examples
+}
diff --git a/eclass/perl-module.eclass b/eclass/perl-module.eclass
index 6285e9363156..ec66990550c3 100644
--- a/eclass/perl-module.eclass
+++ b/eclass/perl-module.eclass
@@ -43,7 +43,9 @@ esac
# dev-lang/perl is automatically added by the eclass. It defaults to yes.
# Set to no to disable, set to noslotop to add a perl dependency without
# slot operator (EAPI=6). All packages installing into the vendor_perl
-# path must use yes here.
+# path must use yes here. (EAPI=8 and later) Also adds a test useflag,
+# a use-conditional build time dependency on virtual/perl-Test-Simple, and
+# the required RESTRICT setting.
case ${EAPI:-0} in
5)
@@ -103,7 +105,7 @@ case ${EAPI:-0} in
EXPORT_FUNCTIONS ${PERL_EXPF}
;;
- *)
+ 7)
[[ ${CATEGORY} == perl-core ]] && \
PERL_EXPF+=" pkg_postinst pkg_postrm"
@@ -130,6 +132,41 @@ case ${EAPI:-0} in
EXPORT_FUNCTIONS ${PERL_EXPF}
;;
+ *)
+ [[ ${CATEGORY} == perl-core ]] && \
+ PERL_EXPF+=" pkg_postinst pkg_postrm"
+
+ case "${GENTOO_DEPEND_ON_PERL:-yes}" in
+ yes)
+ DEPEND="dev-lang/perl"
+ BDEPEND="dev-lang/perl
+ test? ( virtual/perl-Test-Simple )"
+ RDEPEND="dev-lang/perl:="
+ IUSE="test"
+ # RESTRICT="!test? ( test )"
+ # not handled correctly in portage yet
+ ;;
+ noslotop)
+ DEPEND="dev-lang/perl"
+ BDEPEND="dev-lang/perl
+ test? ( virtual/perl-Test-Simple )"
+ RDEPEND="dev-lang/perl"
+ IUSE="test"
+ # RESTRICT="!test? ( test )"
+ # not handled correctly in portage yet
+ ;;
+ esac
+
+ if [[ "${GENTOO_DEPEND_ON_PERL_SUBSLOT:-yes}" != "yes" ]]; then
+ die "GENTOO_DEPEND_ON_PERL_SUBSLOT=no is banned in EAPI=6 and later."
+ fi
+
+ if [[ "${PERL_EXPORT_PHASE_FUNCTIONS}" ]]; then
+ die "PERL_EXPORT_PHASE_FUNCTIONS is banned in EAPI=6 and later."
+ fi
+
+ EXPORT_FUNCTIONS ${PERL_EXPF}
+ ;;
esac
LICENSE="${LICENSE:-|| ( Artistic GPL-1+ )}"