summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-25 05:59:46 +0100
committerSam James <sam@gentoo.org>2023-06-25 05:59:46 +0100
commitd3715f1325c8337fa45366360a21c132dd75cf23 (patch)
tree6b3ebdca3acffbff7c12f9e9b8fac6a6ca53d723
parentsci-electronics/iverilog: Stabilize 12.0 sparc, #909104 (diff)
downloadgentoo-d3715f1325c8337fa45366360a21c132dd75cf23.tar.gz
gentoo-d3715f1325c8337fa45366360a21c132dd75cf23.tar.bz2
gentoo-d3715f1325c8337fa45366360a21c132dd75cf23.zip
sys-devel/boost-m4: add 0.4_p20221019
Closes: https://bugs.gentoo.org/909076 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-devel/boost-m4/Manifest1
-rw-r--r--sys-devel/boost-m4/boost-m4-0.4_p20221019.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/sys-devel/boost-m4/Manifest b/sys-devel/boost-m4/Manifest
index 2c9cc88c4c1b..08d252a9ff90 100644
--- a/sys-devel/boost-m4/Manifest
+++ b/sys-devel/boost-m4/Manifest
@@ -1 +1,2 @@
DIST boost-m4-0.4_p20160328.tar.gz 41253 BLAKE2B 47ad17f652560dce4e276b295e55e7daa8752f1c932a6c0d1bad9e4bc2ff72eb0adfaf8abc4e7c57f179f08857de255935fc530f0a4d8a26d3f6a2a0711417ac SHA512 4aecd311b21ced4a3d62fc706a9fa731c375ea490482f78756892243b5af6909cd8841c249632b37820be7f1bde41c290e842edd933d0c727e1dca76d30eb506
+DIST boost-m4-0.4_p20221019.tar.gz 43301 BLAKE2B 8363b4e5406232050017c5272f5954509d784604485e9c5d485fbb360cebfa366bc0732886c13b54935deb6b1a85632c42282e3a51e92082ac3f40a78e43bbbb SHA512 43bf52054ad820d3da12dca38af7e71c80053a09c9dd06a9a5af87e87bafd69e36b891c179353e5c5e63970c38456264176769df6de8719fd6526116e9971dc6
diff --git a/sys-devel/boost-m4/boost-m4-0.4_p20221019.ebuild b/sys-devel/boost-m4/boost-m4-0.4_p20221019.ebuild
new file mode 100644
index 000000000000..1e9e6c30f506
--- /dev/null
+++ b/sys-devel/boost-m4/boost-m4-0.4_p20221019.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+BOOST_COMMIT="0c955e2c32804d6140676052a9e684ca84bf086d"
+
+DESCRIPTION="Another set of autoconf macros for compiling against boost"
+HOMEPAGE="https://github.com/tsuna/boost.m4"
+SRC_URI="https://github.com/tsuna/boost.m4/archive/${BOOST_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN/-/.}-${BOOST_COMMIT}
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+# boost.m4 has a buildsystem, but the distributer didn't use make dist
+# so we'd have to eautoreconf to use it. Also, its ./configure script
+# DEPENDs on boost. For installing one file, bootstrapping the
+# buildsystem isn't worth it.
+src_configure() { :; }
+
+src_compile() { :; }
+
+src_install() {
+ insinto /usr/share/aclocal
+ doins build-aux/boost.m4
+
+ dodoc AUTHORS NEWS README THANKS
+}