summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2020-07-06 09:35:07 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2020-07-06 09:35:07 +0000
commitfde96b0934f4631714af6431d65dcf9a98999a84 (patch)
treec47e00633cc1553c0af8137133c7a7dda6b5021a
parent2020-07-06 09:05:27 UTC (diff)
parentsys-libs/liburing: Added live ebuild (diff)
downloadgentoo-fde96b0934f4631714af6431d65dcf9a98999a84.tar.gz
gentoo-fde96b0934f4631714af6431d65dcf9a98999a84.tar.bz2
gentoo-fde96b0934f4631714af6431d65dcf9a98999a84.zip
Merge updates from master
-rw-r--r--sys-libs/liburing/liburing-9999.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/sys-libs/liburing/liburing-9999.ebuild b/sys-libs/liburing/liburing-9999.ebuild
new file mode 100644
index 000000000000..13b6926c936a
--- /dev/null
+++ b/sys-libs/liburing/liburing-9999.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal toolchain-funcs
+
+DESCRIPTION="Efficient I/O with io_uring"
+HOMEPAGE="https://github.com/axboe/liburing"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/axboe/liburing.git"
+else
+ SRC_URI="https://git.kernel.dk/cgit/${PN}/snapshot/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+fi
+LICENSE="MIT"
+SLOT="0"
+
+IUSE="static-libs"
+
+src_prepare() {
+ default
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ local myconf=(
+ --prefix="${EPREFIX}/usr"
+ --libdir="${EPREFIX}/usr/$(get_libdir)"
+ --libdevdir="${EPREFIX}/usr/$(get_libdir)"
+ --mandir="${EPREFIX}/usr/share/man"
+ --cc="$(tc-getCC)"
+ )
+ # No autotools configure! "econf" will fail.
+ TMPDIR="${T}" ./configure "${myconf[@]}"
+}
+
+multilib_src_compile() {
+ emake V=1 AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ if ! use static-libs ; then
+ find "${ED}" -type f -name "*.a" -delete || die
+ fi
+}