summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Liffey <amynka@gentoo.org>2017-08-07 10:03:53 +0200
committerAmy Liffey <amynka@gentoo.org>2017-08-07 10:04:38 +0200
commit3f0fe98e778f6209d5f43d95b8ca388b3dd2ed62 (patch)
tree62b96901ae6f096bc80555999a265090978d2fd2 /app-admin/multilog-watch/multilog-watch-1.12-r1.ebuild
parentx11-libs/libxkbcommon: Bump to version 0.7.2 (diff)
downloadgentoo-3f0fe98e778f6209d5f43d95b8ca388b3dd2ed62.tar.gz
gentoo-3f0fe98e778f6209d5f43d95b8ca388b3dd2ed62.tar.bz2
gentoo-3f0fe98e778f6209d5f43d95b8ca388b3dd2ed62.zip
app-admin/multilog-watch: eapi bump to 6
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'app-admin/multilog-watch/multilog-watch-1.12-r1.ebuild')
-rw-r--r--app-admin/multilog-watch/multilog-watch-1.12-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-admin/multilog-watch/multilog-watch-1.12-r1.ebuild b/app-admin/multilog-watch/multilog-watch-1.12-r1.ebuild
new file mode 100644
index 000000000000..a8298e04e6c0
--- /dev/null
+++ b/app-admin/multilog-watch/multilog-watch-1.12-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils
+
+DESCRIPTION="Watches a multilog file for irregularities"
+HOMEPAGE="https://www.eyrie.org/~eagle/software/multilog-watch/"
+SRC_URI="https://archives.eyrie.org/software/system/multilog-watch
+https://www.eyrie.org/%7Eeagle/software/multilog-watch/sample.filter"
+
+LICENSE="Artistic GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ virtual/qmail"
+
+src_unpack() {
+ mkdir "${S}" || die
+ cp "${DISTDIR}"/multilog-watch "${S}" || die
+ cp "${DISTDIR}"/sample.filter "${S}" || die
+}
+
+src_compile() {
+ mv multilog-watch multilog-watch.orig || die
+ sed -e 's/\/etc\/leland/\/etc\/multilog-watch/' multilog-watch.orig > multilog-watch || die
+ /usr/bin/pod2man -s 1 multilog-watch multilog-watch.1 || die
+}
+
+src_install() {
+ dodir /etc/multilog-watch
+ insinto /etc/multilog-watch
+ doins sample.filter
+
+ dobin multilog-watch
+ doman multilog-watch.1
+}