summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-06-22 18:04:49 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-06-22 18:45:20 +0200
commit067f9351ff24d94cc8c09e02c37f355c2694624d (patch)
tree3d8f7abc71fed4de2d4d9e70dec1a3a407fc43df /app-arch
parentdev-java/janino: Stabilize 3.1.7 arm64, #853739 (diff)
downloadgentoo-067f9351ff24d94cc8c09e02c37f355c2694624d.tar.gz
gentoo-067f9351ff24d94cc8c09e02c37f355c2694624d.tar.bz2
gentoo-067f9351ff24d94cc8c09e02c37f355c2694624d.zip
app-arch/bzip3: bump to 1.1.4
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/bzip3/Manifest1
-rw-r--r--app-arch/bzip3/bzip3-1.1.4.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-arch/bzip3/Manifest b/app-arch/bzip3/Manifest
index e1cae6a246f9..adfc61dfdf70 100644
--- a/app-arch/bzip3/Manifest
+++ b/app-arch/bzip3/Manifest
@@ -1,3 +1,4 @@
DIST bzip3-1.1.1.tar.xz 255884 BLAKE2B 09c3b6fdfefc8b82b16f5adf45405d4b61e2188dbe93c1079ffa32560a591c4b5e4f03d0550573d54d79f7c1a4e9d0bf628deddddbf89b17722755248ff6fe41 SHA512 889cdcbf7cbc4972762830d3794c13202b308da039794758d243216f1768a6bbb7660ac4341a3ddb73629c943c830000372e21e1a40b2e1091d05b9e6c54fa26
DIST bzip3-1.1.2.tar.xz 256108 BLAKE2B a5f91fe2760fd4f7f79b908d735d613823dedac23e59950317c26f50d0a657dde042e5a08d401984c14d686d33726caa81e4b34cbca26e28c57a96f61e4f23ab SHA512 8b179bfe9b1b67c516580934cd12a640c86b3f9525c5e7902672051d80198cb91aa8880a4ca3ce14a879d26873405c713f1a0c6a33138d21f4d51c9e93d8fac5
DIST bzip3-1.1.3.tar.xz 257212 BLAKE2B cc94b4c2caa3123b2c775d66143757bcaea7ead6d8a130391d6714583cfcb92fffca47ad80ffc8b5a01483f6cbfab7101c96521cd97e740116c9e10c64c358e8 SHA512 d48695d066ddc79e81c189f8c06e999f8eb8191982db8908f7bd4dfaa0f8fab1ba57e41664962cc6e8611f8398603918e4bd4d58efff2f04292ea54983a6f38d
+DIST bzip3-1.1.4.tar.xz 260404 BLAKE2B ddd087b631c9d5945dea0f4da280dfd74fd303eaed10f7553f770ca18b3b65f00718c073d87e565602a9ed02f4604a0d2dda0ff42cbd38f593bb012f5362cc5c SHA512 86f26b290001d255ad1d2378b5e2d59f9c85e1625ba5d7dca86acd544bb80af95b3379c215a03e0f81f77b7972a852d37746c1028464f404d28a6f9b707383b8
diff --git a/app-arch/bzip3/bzip3-1.1.4.ebuild b/app-arch/bzip3/bzip3-1.1.4.ebuild
new file mode 100644
index 000000000000..0d9329da48ca
--- /dev/null
+++ b/app-arch/bzip3/bzip3-1.1.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A better and stronger spiritual successor to BZip2"
+HOMEPAGE="https://github.com/kspalaiologos/bzip3"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kspalaiologos/${PN}.git"
+else
+ SRC_URI="https://github.com/kspalaiologos/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~loong ~x86"
+fi
+
+LICENSE="LGPL-3+"
+SLOT="0"
+
+src_configure() {
+ # ./configure script will default to Clang if it is found on the system,
+ # force the use of CC selected by the user with CC=$(tc-getCC)
+ econf CC=$(tc-getCC)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}