summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Zander <negril.nx+gentoo@gmail.com>2024-08-14 17:21:17 +0200
committerSam James <sam@gentoo.org>2024-08-25 16:39:58 +0100
commiteff13e3dce975a97160648c2e25b9c60905e6e40 (patch)
tree4a0485471cdab9be3fb84bf43216317b2e6dbad3 /app-arch
parentapp-arch/libdeflate: enable gzip & zlib unconditionally (diff)
downloadgentoo-eff13e3dce975a97160648c2e25b9c60905e6e40.tar.gz
gentoo-eff13e3dce975a97160648c2e25b9c60905e6e40.tar.bz2
gentoo-eff13e3dce975a97160648c2e25b9c60905e6e40.zip
app-arch/libdeflate: add 1.21
Closes: https://bugs.gentoo.org/938174 Signed-off-by: Paul Zander <negril.nx+gentoo@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/38236 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/libdeflate/Manifest1
-rw-r--r--app-arch/libdeflate/libdeflate-1.21.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/app-arch/libdeflate/Manifest b/app-arch/libdeflate/Manifest
index 280c6644dba1..70cf4bec244d 100644
--- a/app-arch/libdeflate/Manifest
+++ b/app-arch/libdeflate/Manifest
@@ -1,2 +1,3 @@
DIST libdeflate-1.19.tar.gz 187684 BLAKE2B 6d3c58b4095f91f64c25e09a062f1d7e68cd43b4dffc2de6484cd941ede4bffd8a82dd3af08eda6c94ad4120d40809c1d6a1814c28bad5387dfbaad418b93070 SHA512 fe57542a0d28ad61d70bef9b544bb6805f9f30930b16432712b3b1caab041f1f4e64315a4306a0635b96c2632239c5af0e45a3915581d0b89975729fc2e95613
DIST libdeflate-1.20.tar.gz 194212 BLAKE2B b3633f1068f36bf346e1f435c67259612ad5ed1571e83f1bbc4a58c6a67b3eadca85e0abb2d2d47f180dd2ff01c5891c8b3958a63ddbcc2447106f2e5cb3c0fe SHA512 5ebe6af9ce81872cba508d1f0aa087ddeb0e0f0c8e6360da66b8a9db2a76203dafbf3d3f6b3b791618ea9c6d0231fab5b4a55badb31a4480fb4174b9445c658b
+DIST libdeflate-1.21.tar.gz 195361 BLAKE2B 8d1f2a71cb6a0823ab93631720f9807a6907f1d92490bb258b9bfcf9daf08b517eab3bdee064326a4274d7b193cffbafa24037e2be2503c17fa8daddef5cfff5 SHA512 7cd9bc91992ef824a0fdf175b0da081b8381decc325013477a3fbfcfe6cf240f66cedbeec830a51343fedb8c27c76fba8782c1aed3fc538e3afd6c9f8cdc90fb
diff --git a/app-arch/libdeflate/libdeflate-1.21.ebuild b/app-arch/libdeflate/libdeflate-1.21.ebuild
new file mode 100644
index 000000000000..12a547db272d
--- /dev/null
+++ b/app-arch/libdeflate/libdeflate-1.21.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+DESCRIPTION="Heavily optimized DEFLATE/zlib/gzip (de)compression"
+HOMEPAGE="https://github.com/ebiggers/libdeflate"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ebiggers/libdeflate.git"
+else
+ SRC_URI="https://github.com/ebiggers/libdeflate/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+# the zlib USE-flag enables support for zlib
+# the test USE-flag programs depend on sys-libs/zlib for comparison tests
+IUSE="+utils test"
+
+RESTRICT="
+ !test? ( test )
+"
+
+DEPEND="
+ test? ( sys-libs/zlib[${MULTILIB_USEDEP}] )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.19-make-gzip-tests-conditional.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DLIBDEFLATE_BUILD_SHARED_LIB="yes"
+ -DLIBDEFLATE_BUILD_STATIC_LIB="no"
+ -DLIBDEFLATE_USE_SHARED_LIB="yes"
+
+ -DLIBDEFLATE_COMPRESSION_SUPPORT="yes"
+ -DLIBDEFLATE_DECOMPRESSION_SUPPORT="yes"
+
+ -DLIBDEFLATE_BUILD_GZIP="$(usex utils)"
+ -DLIBDEFLATE_GZIP_SUPPORT="yes"
+
+ -DLIBDEFLATE_ZLIB_SUPPORT="yes"
+
+ -DLIBDEFLATE_BUILD_TESTS="$(usex test)"
+ )
+
+ cmake-multilib_src_configure
+}