summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-08-16 20:10:55 +0200
committerDavid Seifert <soap@gentoo.org>2020-08-16 20:10:55 +0200
commit8b565d4b9e871dbde172da1a2a356a25684a4f68 (patch)
tree477023d83442638d6de93967f7aa6425f1cb8d1b /app-crypt/nitrokey-app/nitrokey-app-1.4-r1.ebuild
parentdev-perl/Cpanel-JSON-XS: Bump to version 4.210.0 (diff)
downloadgentoo-8b565d4b9e871dbde172da1a2a356a25684a4f68.tar.gz
gentoo-8b565d4b9e871dbde172da1a2a356a25684a4f68.tar.bz2
gentoo-8b565d4b9e871dbde172da1a2a356a25684a4f68.zip
app-crypt/nitrokey-app: Fix installing bash auto-completion
Closes: https://bugs.gentoo.org/736956 Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-crypt/nitrokey-app/nitrokey-app-1.4-r1.ebuild')
-rw-r--r--app-crypt/nitrokey-app/nitrokey-app-1.4-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/app-crypt/nitrokey-app/nitrokey-app-1.4-r1.ebuild b/app-crypt/nitrokey-app/nitrokey-app-1.4-r1.ebuild
new file mode 100644
index 000000000000..faf50aa87f42
--- /dev/null
+++ b/app-crypt/nitrokey-app/nitrokey-app-1.4-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils xdg-utils
+
+DESCRIPTION="Cross platform personalization tool for the Nitrokey"
+HOMEPAGE="https://github.com/Nitrokey/nitrokey-app"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Nitrokey/nitrokey-app"
+
+ # Disable pulling in bundled dependencies
+ EGIT_SUBMODULES=()
+else
+ SRC_URI="https://github.com/Nitrokey/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="amd64 ~ppc64 x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="
+ >=app-crypt/libnitrokey-3.5:=
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/cppcodec"
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-Make-BASH_COMPLETION_DIR-user-overridable.patch )
+
+mycmakeargs=( -DBASH_COMPLETION_PATH=share/bash-completion/completions )
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}