summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/xca
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/xca')
-rw-r--r--app-crypt/xca/Manifest1
-rw-r--r--app-crypt/xca/files/xca-1.0.0-desktop.patch8
-rw-r--r--app-crypt/xca/files/xca-1.1.0-ec.patch124
-rw-r--r--app-crypt/xca/metadata.xml8
-rw-r--r--app-crypt/xca/xca-1.1.0.ebuild44
5 files changed, 185 insertions, 0 deletions
diff --git a/app-crypt/xca/Manifest b/app-crypt/xca/Manifest
new file mode 100644
index 000000000000..48478d93b6df
--- /dev/null
+++ b/app-crypt/xca/Manifest
@@ -0,0 +1 @@
+DIST xca-1.1.0.tar.gz 854925 SHA256 997b62b523f6581f0d96a5f5ba2fa31dcdd2b3cf1ffe924f5c69a931b0dd44df SHA512 c22a594c61f63c71e8bc7c38ccdfabe05903a33bf5116630ca4c5072b725e551a128b10f624d01a464695d739fb9d77a510b3ced99fedc5d5378cb5fd563d954 WHIRLPOOL 1b58ec3dce44e0eb101265f7b1e68695ea2121c795f7d5f6a5349c812469c50f618ce34a5985991432b49a910b2c34fd3eb8e88ac735078a6e063801f1731be0
diff --git a/app-crypt/xca/files/xca-1.0.0-desktop.patch b/app-crypt/xca/files/xca-1.0.0-desktop.patch
new file mode 100644
index 000000000000..0d3516064ded
--- /dev/null
+++ b/app-crypt/xca/files/xca-1.0.0-desktop.patch
@@ -0,0 +1,8 @@
+--- misc/xca.desktop 2012-05-12 05:37:14.000000000 -0400
++++ xca.desktop.new 2013-01-03 19:43:35.877856711 -0500
+@@ -7,5 +7,5 @@
+ Icon=xca-32x32
+ Terminal=false
+-Categories=Application;Utility;Qt;
++Categories=Utility;Qt;
+ MimeType=application/x-xca-database;application/x-xca-template;application/x-x509-ca-cert;application/pkcs10;application/x-pkcs7-certificates;application/x-pkcs12;
diff --git a/app-crypt/xca/files/xca-1.1.0-ec.patch b/app-crypt/xca/files/xca-1.1.0-ec.patch
new file mode 100644
index 000000000000..617f7a14c31e
--- /dev/null
+++ b/app-crypt/xca/files/xca-1.1.0-ec.patch
@@ -0,0 +1,124 @@
+From ca758f29c89d87581b244c652f7a14c8306cc994 Mon Sep 17 00:00:00 2001
+From: Alon Bar-Lev <alon.barlev@gmail.com>
+Date: Wed, 7 Jan 2015 14:43:37 +0200
+Subject: [PATCH] Add more EC conditionals
+
+Upstream bug:
+https://sourceforge.net/p/xca/patches/16/
+
+---
+ lib/pki_scard.cpp | 12 ++++++++++++
+ widgets/MW_help.cpp | 2 +-
+ widgets/NewKey.cpp | 2 +-
+ 3 files changed, 14 insertions(+), 2 deletions(-)
+
+diff --git a/lib/pki_scard.cpp b/lib/pki_scard.cpp
+index 444c81d..547c932 100644
+--- a/lib/pki_scard.cpp
++++ b/lib/pki_scard.cpp
+@@ -237,7 +237,9 @@ pk11_attlist pki_scard::objectAttributesNoId(EVP_PKEY *pk, bool priv) const
+ QByteArray ba;
+ RSA *rsa = pk->pkey.rsa;
+ DSA *dsa = pk->pkey.dsa;
++#ifndef OPENSSL_NO_EC
+ EC_KEY *ec = pk->pkey.ec;
++#endif
+
+ pk11_attlist attrs(pk11_attr_ulong(CKA_CLASS,
+ priv ? CKO_PRIVATE_KEY : CKO_PUBLIC_KEY));
+@@ -254,6 +256,7 @@ pk11_attlist pki_scard::objectAttributesNoId(EVP_PKEY *pk, bool priv) const
+ pk11_attr_data(CKA_SUBPRIME, dsa->q, false) <<
+ pk11_attr_data(CKA_BASE, dsa->g, false);
+ break;
++#ifndef OPENSSL_NO_EC
+ case EVP_PKEY_EC:
+ ba = i2d_bytearray(I2D_VOID(i2d_ECPKParameters),
+ EC_KEY_get0_group(ec));
+@@ -261,6 +264,7 @@ pk11_attlist pki_scard::objectAttributesNoId(EVP_PKEY *pk, bool priv) const
+ attrs << pk11_attr_ulong(CKA_KEY_TYPE, CKK_EC) <<
+ pk11_attr_data(CKA_EC_PARAMS, ba);
+ break;
++#endif
+ default:
+ throw errorEx(QString("Unkown Keytype %d").arg(pk->type));
+
+@@ -330,7 +334,9 @@ void pki_scard::store_token(slotid slot, EVP_PKEY *pkey)
+ QByteArray ba;
+ RSA *rsa = pkey->pkey.rsa;
+ DSA *dsa = pkey->pkey.dsa;
++#ifndef OPENSSL_NO_EC
+ EC_KEY *ec = pkey->pkey.ec;
++#endif
+ pk11_attlist pub_atts;
+ pk11_attlist priv_atts;
+ QList<CK_OBJECT_HANDLE> objects;
+@@ -381,6 +387,7 @@ void pki_scard::store_token(slotid slot, EVP_PKEY *pkey)
+ priv_atts << pk11_attr_data(CKA_VALUE, dsa->priv_key, false);
+ pub_atts << pk11_attr_data(CKA_VALUE, dsa->pub_key, false);
+ break;
++#ifndef OPENSSL_NO_EC
+ case EVP_PKEY_EC: {
+ /* Public Key */
+ BIGNUM *point;
+@@ -410,6 +417,7 @@ void pki_scard::store_token(slotid slot, EVP_PKEY *pkey)
+ EC_KEY_get0_private_key(ec));
+ break;
+ }
++#endif
+ default:
+ throw errorEx(QString("Unkown Keytype %d").arg(pkey->type));
+
+@@ -459,11 +467,13 @@ QList<int> pki_scard::possibleHashNids()
+ case CKM_DSA_SHA1: nids << NID_sha1; break;
+ }
+ break;
++#ifndef OPENSSL_NO_EC
+ case EVP_PKEY_EC:
+ switch (mechanism) {
+ case CKM_ECDSA_SHA1: nids << NID_sha1; break;
+ }
+ break;
++#endif
+ }
+ }
+ if (nids.count() == 0) {
+@@ -473,7 +483,9 @@ QList<int> pki_scard::possibleHashNids()
+ NID_sha384 << NID_sha512 << NID_ripemd160;
+ break;
+ case EVP_PKEY_DSA:
++#ifndef OPENSSL_NO_EC
+ case EVP_PKEY_EC:
++#endif
+ nids << NID_sha1;
+ break;
+ }
+diff --git a/widgets/MW_help.cpp b/widgets/MW_help.cpp
+index 67faa2a..c13c309 100644
+--- a/widgets/MW_help.cpp
++++ b/widgets/MW_help.cpp
+@@ -65,7 +65,7 @@ void MainWindow::about()
+ }
+ #endif
+ #else
+- brainpool = "(Elliptic Curve Cryptography support disabled)"
++ brainpool = "(Elliptic Curve Cryptography support disabled)";
+ #endif
+ openssl = SSLeay_version(SSLEAY_VERSION);
+ qt = qVersion();
+diff --git a/widgets/NewKey.cpp b/widgets/NewKey.cpp
+index 824456d..0dba2c2 100644
+--- a/widgets/NewKey.cpp
++++ b/widgets/NewKey.cpp
+@@ -79,8 +79,8 @@ class keyListItem
+ */
+ ec_flags = CKF_EC_F_P | CKF_EC_F_2M;
+ }
+- }
+ #endif
++ }
+ printname = QString("%1 #%2 (%3 Key of %4 - %5 bits)").
+ arg(ti.label()).arg(ti.serial()).
+ arg(tl->name).
+--
+2.0.5
+
diff --git a/app-crypt/xca/metadata.xml b/app-crypt/xca/metadata.xml
new file mode 100644
index 000000000000..d80f3df4eec7
--- /dev/null
+++ b/app-crypt/xca/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>crypto</herd>
+ <upstream>
+ <remote-id type="sourceforge">xca</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-crypt/xca/xca-1.1.0.ebuild b/app-crypt/xca/xca-1.1.0.ebuild
new file mode 100644
index 000000000000..0ed5bc3a9b3b
--- /dev/null
+++ b/app-crypt/xca/xca-1.1.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A GUI to OpenSSL, RSA public keys, certificates, signing requests and revokation lists"
+HOMEPAGE="http://xca.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="bindist"
+
+RDEPEND=">=dev-libs/openssl-0.9.8:*[bindist=]
+ dev-qt/qtgui:4"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.0.0-desktop.patch
+ epatch "${FILESDIR}"/${P}-ec.patch
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ STRIP=true
+}
+
+src_compile() {
+ # enforce all to avoid the automatic silent rules
+ emake all
+}
+
+src_install() {
+ # non standard destdir
+ emake install destdir="${ED}"
+
+ insinto /etc/xca
+ doins misc/*.txt
+}