summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2023-05-06 00:33:54 +0300
committerSam James <sam@gentoo.org>2023-05-05 23:38:14 +0100
commita9cac53fc6e22aaaa9f8df98fe0d1b1e198d3730 (patch)
tree9fd38059effe6dddfa8824e1bbe3b0b64c5382c3 /app-doc
parentdev-python/pipenv: remove toml dependency (diff)
downloadgentoo-a9cac53fc6e22aaaa9f8df98fe0d1b1e198d3730.tar.gz
gentoo-a9cac53fc6e22aaaa9f8df98fe0d1b1e198d3730.tar.bz2
gentoo-a9cac53fc6e22aaaa9f8df98fe0d1b1e198d3730.zip
app-doc/gimp-help: 2.10.34 revision bump
1. Add BDEPEND 'gnome-base/librsvg' to build Quickreference PDF files. 2. Force LINGUAS="en" if isn't specified in /etc/portage/make.conf to avoid of building all languages. 3. Force 'emake -j1' on install phase to prevent race condition when docs for several languages are built. Closes: https://bugs.gentoo.org/891709 Closes: https://bugs.gentoo.org/905693 Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru> Closes: https://github.com/gentoo/gentoo/pull/30887 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/gimp-help/gimp-help-2.10.34-r1.ebuild (renamed from app-doc/gimp-help/gimp-help-2.10.34.ebuild)25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-doc/gimp-help/gimp-help-2.10.34.ebuild b/app-doc/gimp-help/gimp-help-2.10.34-r1.ebuild
index 4a9d96672c88..2837213514fe 100644
--- a/app-doc/gimp-help/gimp-help-2.10.34.ebuild
+++ b/app-doc/gimp-help/gimp-help-2.10.34-r1.ebuild
@@ -21,13 +21,32 @@ BDEPEND="
app-text/docbook-xml-dtd
dev-lang/perl
dev-libs/libxslt
+ gnome-base/librsvg
sys-devel/gettext
"
+DOCS=( AUTHORS COPYING NEWS README )
+
python_check_deps() {
python_has_version "dev-libs/libxml2[python,${PYTHON_USEDEP}]"
}
+pkg_setup() {
+ # See bug: 891709
+ if [[ -z "${LINGUAS}" ]] ; then
+ export LINGUAS="en"
+
+ ewarn "The 'LINGUAS' environment variable isn't setup in '/etc/portage/make.conf',"
+ ewarn "therefore only the generic ('en') documentation will be built."
+ ewarn "To build ${PN} for other languages please setup 'LINGUAS' variable"
+ ewarn "or assign it to 'L10N' variable if available, i.e. LINGUAS=\"\${L10N}\""
+ ewarn "The following languages are supported for ${PN}:"
+ ewarn "'ca cs da de el en en_GB es fa fi fr hr hu it ja ko lt nl nn pt pt_BR ro ru sl sv uk zh_CN'"
+ ewarn "For more details please read:"
+ ewarn "https://wiki.gentoo.org/wiki/Localization/Guide#LINGUAS"
+ fi
+}
+
src_configure() {
econf --without-gimp
}
@@ -38,3 +57,9 @@ src_compile() {
# Affected with bugs: 677198, 876205. Set "emake -j1"
emake -j1
}
+
+src_install() {
+ # See bug: 905693
+ emake -j1 DESTDIR="${D}" install
+ einstalldocs
+}