summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-07-10 16:42:12 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-07-10 20:55:56 +0200
commit379e3705228f8b90252d22fde5c285005be2ae9a (patch)
tree997b32c62b762c2f9bb4fe808fcb47ff7e2655e1 /app-emacs/helm
parentapp-emacs/helm: drop old 3.8.7 (diff)
downloadgentoo-379e3705228f8b90252d22fde5c285005be2ae9a.tar.gz
gentoo-379e3705228f8b90252d22fde5c285005be2ae9a.tar.bz2
gentoo-379e3705228f8b90252d22fde5c285005be2ae9a.zip
app-emacs/helm: bump to 3.9.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/helm')
-rw-r--r--app-emacs/helm/Manifest1
-rw-r--r--app-emacs/helm/helm-3.9.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/app-emacs/helm/Manifest b/app-emacs/helm/Manifest
index 55ab9c43fbb6..e9911191e5ed 100644
--- a/app-emacs/helm/Manifest
+++ b/app-emacs/helm/Manifest
@@ -1,2 +1,3 @@
DIST helm-3.8.8.tar.gz 2362007 BLAKE2B 80f854bc38e51de62aa6d9a35cdeff4ac4c193908dc19361ad10ad419585d30a2fd94be1d4d410b69634012e4c01045d4dd2f55c5b4ac8da960d7f7b8d4eed08 SHA512 a1fca373d2c64771aabb3ba396e0d65b3434f0a413bab1e61761c16e9dcf274ceb94e258ef90f4ddd2b150a09606255ea61186d2e4e69ad2600fc40369c693c7
DIST helm-3.9.0.tar.gz 2366592 BLAKE2B 8aeaecf444127dc9758c1116c2f2b6d6a11515b7a549444ba13cc2e6cb48c301ff76343220af2328af89050e210ceed00b5c45e9dee0c0546c40066b5c0bde0a SHA512 bf3917fb06e7d841fddb0b7a0f493dd18ea73568e84c2a535f3fffa1582efb65268a668f23871f66d221caa8be166b667e43095adb59342e3b2a130c5a59d708
+DIST helm-3.9.1.tar.gz 2370645 BLAKE2B 819f0bf8cbd3728a78e90da6955f799a8ad2320323a9a16eb72a4fcfe21c04995f0fd0072a7a8bf6fcf593dedc4c3b224f0310ec317b9e39f326b4c147343b1b SHA512 7cd5d93493a08ec173b6786ec4e0cbaf3a90473f7ef8f7564232cedc438ed01466faeb8aced07419aedadd1469c8c43fe6072ee725643e133ceb3004675dc3b7
diff --git a/app-emacs/helm/helm-3.9.1.ebuild b/app-emacs/helm/helm-3.9.1.ebuild
new file mode 100644
index 000000000000..76671b3b26bc
--- /dev/null
+++ b/app-emacs/helm/helm-3.9.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Emacs incremental completion and selection narrowing framework"
+HOMEPAGE="https://emacs-helm.github.io/helm/
+ https://github.com/emacs-helm/helm/"
+SRC_URI="https://github.com/emacs-helm/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-emacs/async
+ app-emacs/popup
+"
+BDEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-3.8.8-no-autoload-check.patch )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file
+}
+
+src_install() {
+ elisp_src_install
+
+ exeinto /usr/bin/
+ doexe emacs-helm.sh
+}