summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-04-18 02:31:44 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-04-18 02:35:47 +0200
commitc12e9953e79891fd785befa8078813a18b6a4f58 (patch)
treec1dd83bc5c401177a2c36b3a7922008e4e4ca5e0 /app-emacs/treemacs
parentapp-emacs/a: use elisp-enable-tests (diff)
downloadgentoo-c12e9953e79891fd785befa8078813a18b6a4f58.tar.gz
gentoo-c12e9953e79891fd785befa8078813a18b6a4f58.tar.bz2
gentoo-c12e9953e79891fd785befa8078813a18b6a4f58.zip
app-emacs/treemacs: use elisp-enable-tests
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/treemacs')
-rw-r--r--app-emacs/treemacs/treemacs-3.1.ebuild15
1 files changed, 4 insertions, 11 deletions
diff --git a/app-emacs/treemacs/treemacs-3.1.ebuild b/app-emacs/treemacs/treemacs-3.1.ebuild
index de552c5b30b2..6d097c74f261 100644
--- a/app-emacs/treemacs/treemacs-3.1.ebuild
+++ b/app-emacs/treemacs/treemacs-3.1.ebuild
@@ -7,7 +7,7 @@ NEED_EMACS=26.1
DISTUTILS_USE_PEP517=no
PYTHON_COMPAT=( python3_{9..11} )
-inherit elisp distutils-r1
+inherit distutils-r1 elisp
DESCRIPTION="Tree style project file explorer"
HOMEPAGE="https://github.com/Alexander-Miller/treemacs/"
@@ -17,8 +17,6 @@ SRC_URI="https://github.com/Alexander-Miller/${PN}/archive/${PV}.tar.gz
LICENSE="GPL-3+"
KEYWORDS="~amd64"
SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="
app-emacs/ace-window
@@ -29,10 +27,7 @@ RDEPEND="
app-emacs/pfuture
app-emacs/s
"
-BDEPEND="
- ${RDEPEND}
- test? ( app-emacs/buttercup )
-"
+BDEPEND="${RDEPEND}"
BYTECOMPFLAGS="-L . -L src/elisp"
PATCHES=(
@@ -44,6 +39,8 @@ PATCHES=(
DOCS=( Changelog.org Extensions.org README.org screenshots )
SITEFILE="50${PN}-gentoo.el"
+elisp-enable-tests buttercup test
+
src_prepare() {
distutils-r1_src_prepare
@@ -62,10 +59,6 @@ src_compile() {
elisp-compile src/elisp/*.el
}
-src_test() {
- buttercup ${BYTECOMPFLAGS} -L test --traceback full || die "tests failed"
-}
-
src_install() {
elisp-install ${PN} src/elisp/*.el{,c}
elisp-site-file-install "${FILESDIR}/${SITEFILE}"