summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-10-13 21:09:20 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-10-13 21:23:14 +0200
commitb61959ab4621af966575e4830f425f8252c40f7d (patch)
treee2e6a3664220046a9e051fa9421c39813688f6f2 /app-emacs
parentapp-emacs/gptel: bump to 0.9.5 (diff)
downloadgentoo-b61959ab4621af966575e4830f425f8252c40f7d.tar.gz
gentoo-b61959ab4621af966575e4830f425f8252c40f7d.tar.bz2
gentoo-b61959ab4621af966575e4830f425f8252c40f7d.zip
app-emacs/eldev: bump to 1.10.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/eldev/Manifest1
-rw-r--r--app-emacs/eldev/eldev-1.10.2.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/app-emacs/eldev/Manifest b/app-emacs/eldev/Manifest
index cc69c00ee7b9..007081218c11 100644
--- a/app-emacs/eldev/Manifest
+++ b/app-emacs/eldev/Manifest
@@ -1 +1,2 @@
DIST eldev-1.10.1.tar.gz 307097 BLAKE2B e86dbd717faca925c57c3331d2a5177e6ae96959b2425a1a62082ce268650f08b40744cab819f948d26c752523764ae330c6c57cffd0f1bcc440b8c0b4ea75b2 SHA512 8be7913457e826d10eea4625d5f412996e3b485d9d65749bcdc9bb020fac33aa41840d856e31fefe9a2f4b5a9dc597be8820416eaed96717287b8a966f663861
+DIST eldev-1.10.2.tar.gz 307514 BLAKE2B 9da91154ad464971798d6430d398b90c078e8cf32460c0bb1056d67a1e2599e33f9ee81d3e0d7c9dcd44e12c3c6d0cbcac459a714cb855ea454b78bc01fb315e SHA512 d82543271c235d25069008d87e885800342c4b13cf26adbd2cb9a64dfa224352c0019a322916191594b1be926d29830abbee8abbef1175a705d28e003f040ca3
diff --git a/app-emacs/eldev/eldev-1.10.2.ebuild b/app-emacs/eldev/eldev-1.10.2.ebuild
new file mode 100644
index 000000000000..c7b3f8685f75
--- /dev/null
+++ b/app-emacs/eldev/eldev-1.10.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Emacs Lisp Development Tool"
+HOMEPAGE="https://emacs-eldev.github.io/eldev/
+ https://github.com/doublep/eldev/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/doublep/${PN}.git"
+else
+ SRC_URI="https://github.com/doublep/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~arm ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+ELISP_REMOVE="
+ test/doctor.el
+"
+
+DOCS=( README.adoc )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ELDEV_LOCAL="${S}" "./bin/${PN}" test
+}
+
+src_install() {
+ elisp_src_install
+
+ exeinto /usr/bin
+ doexe "./bin/${PN}"
+
+ # NOTICE: If ELDEV_LOCAL is defined Eldev will use it
+ # to load up it's components,
+ # if it is not it will bootstrap itself from network
+ # always check if it uses installed Emacs Lisp files.
+ # Also, do not forget to run `env-update` & reopen your shell.
+ # https://github.com/doublep/eldev#influential-environment-variables
+ echo "ELDEV_LOCAL=${SITELISP}/${PN}" >> "${T}/99${PN}" || die
+ doenvd "${T}/99${PN}"
+}
+
+pkg_postinst() {
+ elisp_pkg_postinst
+
+ ewarn "Remember to run \`env-update && source /etc/profile\` if you plan"
+ ewarn "to use Eldev in a shell before logging out (or restarting"
+ ewarn "your login manager)."
+}