summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-02-02 17:59:46 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-02-02 17:59:46 +0100
commit057a1b5dba007770122e4b6e045f0b0a1c254cba (patch)
tree65449dabed6b27c7ee6126d4e4f27265835c5162 /app-emulation/spice
parentmedia-tv/xawtv: Remove old and drop to unstable (diff)
downloadgentoo-057a1b5dba007770122e4b6e045f0b0a1c254cba.tar.gz
gentoo-057a1b5dba007770122e4b6e045f0b0a1c254cba.tar.bz2
gentoo-057a1b5dba007770122e4b6e045f0b0a1c254cba.zip
app-emulation/spice: Version bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'app-emulation/spice')
-rw-r--r--app-emulation/spice/Manifest1
-rw-r--r--app-emulation/spice/spice-0.13.0.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/app-emulation/spice/Manifest b/app-emulation/spice/Manifest
index cd51bb5e3c5d..4d02ae787819 100644
--- a/app-emulation/spice/Manifest
+++ b/app-emulation/spice/Manifest
@@ -1 +1,2 @@
DIST spice-0.12.6.tar.bz2 1181088 SHA256 f148ea30135bf80a4f465ce723a1cd6d4ccb34c098b6298a020b378ace8569b6 SHA512 877d9c447a09055c61db7839ae1a2bbd97ab1178d8fd30fff83883064f8a2f269479649e696732095833ed3fda2d0cc0cbe2a420decb89d36d2cf2f18ad9a3db WHIRLPOOL e381cf469a29be9a91ab442ee5f426a44ee569528d9297401df1c927cbf558e9daee7709cd69a4cc6389481b0c5aa26b19e56f0e97576e270d768842581544fe
+DIST spice-0.13.0.tar.bz2 1215334 SHA256 4862e2d11da10abdf46dd6cc834d79fa4ef3490efac8dbcdd19fa96f81147bbb SHA512 be9960e8f40415f2d0c2445aca701729f904b4598492b64993fc53b2cfb27652642f11721b43c44c953e6ba4982865b15260c995bb12c4f29ea9c7e962043795 WHIRLPOOL 88d92a4498e76eb279c073e4da87a0b0efe7697f6da1211b4830681a1cc6c828809dcaaec54e0876766a8fd4365e55439910c13c03e7a50d0ccbdcf98bbec781
diff --git a/app-emulation/spice/spice-0.13.0.ebuild b/app-emulation/spice/spice-0.13.0.ebuild
new file mode 100644
index 000000000000..9f06219e096b
--- /dev/null
+++ b/app-emulation/spice/spice-0.13.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4} )
+
+inherit eutils python-any-r1
+
+DESCRIPTION="SPICE server"
+HOMEPAGE="http://spice-space.org/"
+SRC_URI="http://spice-space.org/download/releases/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl sasl smartcard static-libs"
+
+# the libspice-server only uses the headers of libcacard
+RDEPEND="
+ >=dev-libs/glib-2.22:2[static-libs(+)?]
+ >=media-libs/celt-0.5.1.1:0.5.1[static-libs(+)?]
+ media-libs/opus[static-libs(+)?]
+ sys-libs/zlib[static-libs(+)?]
+ virtual/jpeg:0=[static-libs(+)?]
+ >=x11-libs/pixman-0.17.7[static-libs(+)?]
+ !libressl? ( dev-libs/openssl:0[static-libs(+)?] )
+ libressl? ( dev-libs/libressl[static-libs(+)?] )
+ smartcard? ( >=app-emulation/libcacard-0.1.2 )
+ sasl? ( dev-libs/cyrus-sasl[static-libs(+)?] )"
+
+DEPEND="
+ >=app-emulation/spice-protocol-0.12.10
+ virtual/pkgconfig
+ $(python_gen_any_dep '
+ >=dev-python/pyparsing-1.5.6-r2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ ')
+ smartcard? ( app-emulation/qemu[smartcard] )
+ ${RDEPEND}"
+
+python_check_deps() {
+ has_version ">=dev-python/pyparsing-1.5.6-r2[${PYTHON_USEDEP}]"
+ has_version "dev-python/six[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && python-any-r1_pkg_setup
+}
+
+# maintainer notes:
+# * opengl support is currently broken
+
+src_prepare() {
+ epatch "${FILESDIR}/0.11.0-gold.patch"
+
+ epatch_user
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with sasl) \
+ $(use_enable smartcard) \
+ --disable-gui
+}
+
+src_install() {
+ default
+ use static-libs || prune_libtool_files
+}