summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Sarnie <sarnex@gentoo.org>2020-12-09 09:29:51 -0500
committerNick Sarnie <sarnex@gentoo.org>2020-12-09 09:30:11 -0500
commitc6819407638261478bcdb2db31ae0c7414192885 (patch)
tree29ddbda3161f2da80ba4a4b5bdaa0ff989548776 /app-emulation/wine-gecko/wine-gecko-2.47.2.ebuild
parentpackage.mask: Masked >=sys-devel/autoconf-2.70 for testing (diff)
downloadgentoo-c6819407638261478bcdb2db31ae0c7414192885.tar.gz
gentoo-c6819407638261478bcdb2db31ae0c7414192885.tar.bz2
gentoo-c6819407638261478bcdb2db31ae0c7414192885.zip
app-emulation/wine-gecko: Sync with ::wine
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Nick Sarnie <sarnex@gentoo.org>
Diffstat (limited to 'app-emulation/wine-gecko/wine-gecko-2.47.2.ebuild')
-rw-r--r--app-emulation/wine-gecko/wine-gecko-2.47.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-emulation/wine-gecko/wine-gecko-2.47.2.ebuild b/app-emulation/wine-gecko/wine-gecko-2.47.2.ebuild
new file mode 100644
index 000000000000..6f99f662aee1
--- /dev/null
+++ b/app-emulation/wine-gecko/wine-gecko-2.47.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A Mozilla Gecko based version of Internet Explorer for Wine"
+HOMEPAGE="https://winehq.org"
+SRC_URI="
+ abi_x86_32? ( https://dl.winehq.org/wine/${PN}/${PV}/${PN}-${PV}-x86.msi )
+ abi_x86_64? ( https://dl.winehq.org/wine/${PN}/${PV}/${PN}-${PV}-x86_64.msi )
+"
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT MPL-2.0"
+SLOT="${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="abi_x86_32 abi_x86_64"
+
+DEPEND="!!app-emulation/wine:0"
+
+S="${WORKDIR}"
+
+src_install(){
+ insinto /usr/share/wine/gecko
+ use abi_x86_32 && doins "${DISTDIR}/${PN}-${PV}-x86.msi"
+ use abi_x86_64 && doins "${DISTDIR}/${PN}-${PV}-x86_64.msi"
+}