summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-08-08 08:00:27 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-08-08 08:00:27 +0200
commitd58ded4487b28996f96dcc96ca256d2995c16721 (patch)
tree08352f3a5ec3294d632408a91245560c8cbe56cf /app-forensics
parentnet-misc/fatrat: Removed old. (diff)
downloadgentoo-d58ded4487b28996f96dcc96ca256d2995c16721.tar.gz
gentoo-d58ded4487b28996f96dcc96ca256d2995c16721.tar.bz2
gentoo-d58ded4487b28996f96dcc96ca256d2995c16721.zip
app-forensics/rkhunter: Bump to version 1.4.4
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/rkhunter/Manifest1
-rw-r--r--app-forensics/rkhunter/rkhunter-1.4.4.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/app-forensics/rkhunter/Manifest b/app-forensics/rkhunter/Manifest
index cf1cea219dda..2a6fab9b9d80 100644
--- a/app-forensics/rkhunter/Manifest
+++ b/app-forensics/rkhunter/Manifest
@@ -1 +1,2 @@
DIST rkhunter-1.4.2.tar.gz 277707 SHA256 789cc84a21faf669da81e648eead2e62654cfbe0b2d927119d8b1e55b22b65c3 SHA512 a4e45caaaf5b8262619ebb890784c75c4e30db4c6c0eba305f86d419142b4796c95bc55fe8846dce8d58bc7636bdb365a4a8c41707f64d4d81373687c5a3b0d4 WHIRLPOOL 911ed8e37e112516adba3afb63e3d4862d061ea35cd4b8becea455922d6b2a744f4b8e7cf92685cff29c3192c594dfc58ba3c194f371dd4d95530bd4c09c5d84
+DIST rkhunter-1.4.4.tar.gz 297626 SHA256 a8807c83f9f325312df05aa215fa75ad697c7a16163175363c2066baa26dda77 SHA512 87e9c617220765678cc4519eee27d1d56185c3a7fb1d6338c8fb984ac4f5176c31bb54b69e1de615d66a0cf1e72b672e66b368e37851a459def69463cbb8661e WHIRLPOOL 92c92a693443c978aa7f49944e84075b116c8c4295ff8e9ad54e2bee8242299aaea2d591a9a184dc484b73b33f61210c8b87cfdcea4f2437e386f633ba12f2cb
diff --git a/app-forensics/rkhunter/rkhunter-1.4.4.ebuild b/app-forensics/rkhunter/rkhunter-1.4.4.ebuild
new file mode 100644
index 000000000000..14a44125016c
--- /dev/null
+++ b/app-forensics/rkhunter/rkhunter-1.4.4.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1
+
+DESCRIPTION="Rootkit Hunter scans for known and unknown rootkits, backdoors, and sniffers"
+HOMEPAGE="http://rkhunter.sf.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ app-shells/bash
+ dev-lang/perl
+ sys-process/lsof[rpc]
+ virtual/cron
+ virtual/mailx
+"
+
+S="${WORKDIR}/${P}/files"
+
+src_prepare() {
+ default
+ eapply -p2 "${FILESDIR}/${PN}-1.4.2.conf.patch"
+}
+
+src_install() {
+ # rkhunter requires to be root
+ dosbin ${PN}
+
+ insinto /etc
+ doins ${PN}.conf
+
+ exeinto /usr/lib/${PN}/scripts
+ doexe *.pl
+
+ insinto /var/lib/${PN}/db
+ doins *.dat
+
+ insinto /var/lib/${PN}/db/i18n
+ doins i18n/*
+
+ doman ${PN}.8
+ dodoc ACKNOWLEDGMENTS CHANGELOG FAQ README
+
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}/${PN}-1.3.cron" ${PN}
+
+ newbashcomp "${FILESDIR}/${PN}.bash-completion" ${PN}
+}
+
+pkg_postinst() {
+ elog "A cron script has been installed to /etc/cron.daily/rkhunter."
+ elog "To enable it, edit /etc/cron.daily/rkhunter and follow the"
+ elog "directions."
+ elog "If you want ${PN} to send mail, you will need to install"
+ elog "virtual/mailx or alter the EMAIL_CMD variable in the"
+ elog "cron script and possibly the MAIL_CMD variable in the"
+ elog "${PN}.conf file to use another mail client."
+}