summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Breathitt Gray <vilhelm.gray@gmail.com>2020-05-07 15:33:32 -0400
committerAkinori Hattori <hattya@gentoo.org>2020-05-12 23:10:15 +0900
commitfa292aeff7ca2bf3d3220f7ca729c656162e7e98 (patch)
tree6e80726a64ed10112712e63ed1300e5fd491c43f /app-i18n/ibus-anthy
parentdev-python/python-evdev: drop old version (diff)
downloadgentoo-fa292aeff7ca2bf3d3220f7ca729c656162e7e98.tar.gz
gentoo-fa292aeff7ca2bf3d3220f7ca729c656162e7e98.tar.bz2
gentoo-fa292aeff7ca2bf3d3220f7ca729c656162e7e98.zip
app-i18n/ibus-anthy: Version bump to 1.5.11
Closes: https://bugs.gentoo.org/721138 Closes: https://github.com/gentoo/gentoo/pull/15687 Signed-off-by: William Breathitt Gray <vilhelm.gray@gmail.com> Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n/ibus-anthy')
-rw-r--r--app-i18n/ibus-anthy/Manifest1
-rw-r--r--app-i18n/ibus-anthy/ibus-anthy-1.5.11.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/app-i18n/ibus-anthy/Manifest b/app-i18n/ibus-anthy/Manifest
index 6c20199d807a..0d7178973c8c 100644
--- a/app-i18n/ibus-anthy/Manifest
+++ b/app-i18n/ibus-anthy/Manifest
@@ -1,2 +1,3 @@
+DIST ibus-anthy-1.5.11.tar.gz 809725 BLAKE2B b12139e208c401e3fdda0d3a184b0246d039e077b827d1aeb2da20470deeb62551026c68ba39c289e7876467147a6ba93d318d0582a9b45866c2f5a4f52e85aa SHA512 2ac85bf4ddba56e3f84c3732082b3b63a07175ea712aad2865de4f87b8c0967da303ee1edccbed0890095e8ddab10e58307a47b72ee11b51de3927fdb9e72418
DIST ibus-anthy-1.5.10.tar.gz 758528 BLAKE2B 39496f5c3a5f2038f3f81e09504e472a32da85f27701741cbe77b576afcd8685c4f2209aaf24ef84420cbeec1614b251d2903c1ea4e7175a1014f92615399847 SHA512 963b1dfba18259aad2296c10de35f9f321b0169d6f85afa058ed57b6894fe4e1d44514ffadeee3c3108aac77f54aa645096ddf4bdb353fafaedb83d27d8c5d47
DIST ibus-anthy-1.5.9.tar.gz 765672 BLAKE2B 88a2b935bfe1007bdcbd70af358509da77533a67df4b6d0be218b5f9d5e1c0ca093e62618765f1e2d7c06c2127458319bbf482ce8598398b9562ecec8a258301 SHA512 2f57db784ddbd4ea57afba245dc532fe4ee8c9fea5fc7df9b3ca26600816ef4c0626b4ebdbbd976826c391890216af587863707caa26c3926a6278cc6b720ef6
diff --git a/app-i18n/ibus-anthy/ibus-anthy-1.5.11.ebuild b/app-i18n/ibus-anthy/ibus-anthy-1.5.11.ebuild
new file mode 100644
index 000000000000..69b11608af81
--- /dev/null
+++ b/app-i18n/ibus-anthy/ibus-anthy-1.5.11.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_7 )
+
+inherit gnome2-utils python-single-r1
+
+DESCRIPTION="Japanese Anthy engine for IBus"
+HOMEPAGE="https://github.com/ibus/ibus/wiki"
+SRC_URI="https://github.com/ibus/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ app-i18n/anthy
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_MULTI_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ ')
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ default
+ gnome2_environment_reset
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ --enable-private-png \
+ --with-layout=default \
+ --with-python=${EPYTHON}
+}
+
+src_test() {
+ :
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+
+ python_optimize
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+
+ if ! has_version app-dicts/kasumi; then
+ elog "app-dicts/kasumi is not required but probably useful for you."
+ fi
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}