summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/hddled
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/hddled')
-rw-r--r--app-misc/hddled/Manifest1
-rw-r--r--app-misc/hddled/hddled-0.3.ebuild41
-rw-r--r--app-misc/hddled/metadata.xml9
3 files changed, 51 insertions, 0 deletions
diff --git a/app-misc/hddled/Manifest b/app-misc/hddled/Manifest
new file mode 100644
index 000000000000..d930f4beca1f
--- /dev/null
+++ b/app-misc/hddled/Manifest
@@ -0,0 +1 @@
+DIST hddled-0.3.c.xz 3108 SHA256 abb2ad3a654419bb5e92e909674ef12aa5adc79d65b88c802060082e7b8fff2f SHA512 9f535557aff78d3c9693a8d34810a768e8306de73841ba0d0a928a5d205a8a5faf632a9bf51db8763b5d8d2b3de73ee6f06af62f1a0025b0912c7c18133cdf19 WHIRLPOOL 35f7f73a6186cac079adf36737f0f88f9addbd2ed289dca4a88b87e717a7ab42a078710a4e0355243cd4f238d31837d36d26df2b79b3ffecbbb80b37105f18b0
diff --git a/app-misc/hddled/hddled-0.3.ebuild b/app-misc/hddled/hddled-0.3.ebuild
new file mode 100644
index 000000000000..18f1c2fa5d47
--- /dev/null
+++ b/app-misc/hddled/hddled-0.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Show hard disk activity using the scroll lock LED"
+HOMEPAGE="http://members.optusnet.com.au/foonly/whirlpool/code/"
+SRC_URI="mirror://gentoo/${P}.c.xz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X"
+
+DEPEND="X? ( x11-libs/libX11 )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ mv ${P}.c ${PN}.c || die
+}
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} -o ${PN} ${PN}.c ${LDFLAGS} || die
+ if use X ; then
+ $(tc-getCC) ${CFLAGS} -DX -lX11 -o x${PN} ${PN}.c ${LDFLAGS} || die
+ fi
+}
+
+src_install() {
+ dobin ${PN} || die
+ if use X ; then
+ dobin x${PN} || die
+ elog "X version was renamed to x${PN}"
+ fi
+}
diff --git a/app-misc/hddled/metadata.xml b/app-misc/hddled/metadata.xml
new file mode 100644
index 000000000000..59acc2cc580e
--- /dev/null
+++ b/app-misc/hddled/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>xmw@gentoo.org</email>
+<name>Michael Weber</name>
+</maintainer>
+</pkgmetadata>
+