summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/jq
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/jq')
-rw-r--r--app-misc/jq/Manifest1
-rw-r--r--app-misc/jq/files/jq-1.4-dynamic-link.patch12
-rw-r--r--app-misc/jq/jq-1.4-r1.ebuild40
-rw-r--r--app-misc/jq/jq-1.4.ebuild32
-rw-r--r--app-misc/jq/metadata.xml8
5 files changed, 93 insertions, 0 deletions
diff --git a/app-misc/jq/Manifest b/app-misc/jq/Manifest
new file mode 100644
index 000000000000..b9320a7f4dc3
--- /dev/null
+++ b/app-misc/jq/Manifest
@@ -0,0 +1 @@
+DIST jq-1.4.tar.gz 578317 SHA256 998c41babeb57b4304e65b4eb73094279b3ab1e63801b6b4bddd487ce009b39d SHA512 02e601b713a3249bcfe5373153dff38a63bf504895181ca3f691dbf033b407373a9c5880001bbd1954123cdf89f4fe75e2a5168e7a7cf13b3f7355dc18f92458 WHIRLPOOL 93c85a40d8aaf36d1f846ee9050aebe32a3a135e89a64647688b447af8733d210a4716d4ee62271a7d33f2e498e8aee7b2e88ed5373d0ec07e810215c1d288ab
diff --git a/app-misc/jq/files/jq-1.4-dynamic-link.patch b/app-misc/jq/files/jq-1.4-dynamic-link.patch
new file mode 100644
index 000000000000..b958a1556125
--- /dev/null
+++ b/app-misc/jq/files/jq-1.4-dynamic-link.patch
@@ -0,0 +1,12 @@
+do not statically link libjq since we install it
+
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -53,7 +53,6 @@
+
+ bin_PROGRAMS = jq
+ jq_SOURCES = main.c
+-jq_LDFLAGS = -static-libtool-libs
+ jq_LDADD = libjq.la -lm
+
+ ### Tests (make check)
diff --git a/app-misc/jq/jq-1.4-r1.ebuild b/app-misc/jq/jq-1.4-r1.ebuild
new file mode 100644
index 000000000000..418c2e1bc880
--- /dev/null
+++ b/app-misc/jq/jq-1.4-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="A lightweight and flexible command-line JSON processor"
+HOMEPAGE="http://stedolan.github.com/jq/"
+SRC_URI="http://stedolan.github.io/jq/download/source/${P}.tar.gz"
+
+LICENSE="MIT CC-BY-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs test"
+
+DEPEND="sys-devel/bison
+ sys-devel/flex
+ test? ( dev-util/valgrind )"
+
+DOCS=( AUTHORS README )
+
+src_prepare() {
+ sed -i '/^dist_doc_DATA/d' Makefile.am || die
+ epatch "${FILESDIR}"/${PN}-1.4-dynamic-link.patch
+ eautoreconf
+}
+
+src_configure() {
+ # don't try to rebuild docs
+ econf \
+ --disable-docs \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use static-libs || find "${ED}" -name libjq.la -delete
+}
diff --git a/app-misc/jq/jq-1.4.ebuild b/app-misc/jq/jq-1.4.ebuild
new file mode 100644
index 000000000000..5a02642a07a7
--- /dev/null
+++ b/app-misc/jq/jq-1.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="A lightweight and flexible command-line JSON processor"
+HOMEPAGE="http://stedolan.github.com/jq/"
+SRC_URI="http://stedolan.github.io/jq/download/source/${P}.tar.gz"
+
+LICENSE="MIT CC-BY-3.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+DEPEND="sys-devel/bison
+ sys-devel/flex
+ test? ( dev-util/valgrind )"
+
+DOCS=( AUTHORS README )
+
+src_prepare() {
+ sed -i '/^dist_doc_DATA/d' Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ # don't try to rebuild docs
+ econf --disable-docs
+}
diff --git a/app-misc/jq/metadata.xml b/app-misc/jq/metadata.xml
new file mode 100644
index 000000000000..efa5eb0078f3
--- /dev/null
+++ b/app-misc/jq/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version = '1.0' encoding = 'UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
+</pkgmetadata>