summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-05-13 22:22:46 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-05-13 23:04:49 +0200
commit9f931add535999062f001fe53e4e2f78e5fdec41 (patch)
tree8e8119aa2b77835ab66660ef139598b1482aacc9 /app-misc/ktoblzcheck/ktoblzcheck-1.49.ebuild
parentapp-misc/screen: stable 4.6.1 for hppa/sparc (diff)
downloadgentoo-9f931add535999062f001fe53e4e2f78e5fdec41.tar.gz
gentoo-9f931add535999062f001fe53e4e2f78e5fdec41.tar.bz2
gentoo-9f931add535999062f001fe53e4e2f78e5fdec41.zip
app-misc/ktoblzcheck: 1.49 version bump
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'app-misc/ktoblzcheck/ktoblzcheck-1.49.ebuild')
-rw-r--r--app-misc/ktoblzcheck/ktoblzcheck-1.49.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-misc/ktoblzcheck/ktoblzcheck-1.49.ebuild b/app-misc/ktoblzcheck/ktoblzcheck-1.49.ebuild
new file mode 100644
index 000000000000..4465f59fe022
--- /dev/null
+++ b/app-misc/ktoblzcheck/ktoblzcheck-1.49.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1
+
+DESCRIPTION="Library to check account numbers and bank codes of German banks"
+HOMEPAGE="http://ktoblzcheck.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="python"
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="
+ app-text/recode
+ sys-apps/grep
+ sys-apps/sed
+ virtual/awk
+ || ( net-misc/wget www-client/lynx )
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="${RDEPEND}
+ sys-devel/libtool
+"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ econf $(use_enable python)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}