summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZ. Liu <zhixu.liu@gmail.com>2024-12-13 17:39:03 +0800
committerSam James <sam@gentoo.org>2024-12-24 09:20:47 +0000
commit01e878219667bf8ce1781f7b74758ecf40ecb80b (patch)
tree03337ed571831dd5115946765cce3253ea4f5a3c /app-misc
parentapp-i18n/uim: use set-face-underline (diff)
downloadgentoo-01e878219667bf8ce1781f7b74758ecf40ecb80b.tar.gz
gentoo-01e878219667bf8ce1781f7b74758ecf40ecb80b.tar.bz2
gentoo-01e878219667bf8ce1781f7b74758ecf40ecb80b.zip
app-misc/beep: fix issue when no caps on fs w/o xattr support
1. set mode so fcaps won't set SUID if fs w/o xattr support 2. show message tell user howto run as non-root user 3. add more doc files Closes: https://bugs.gentoo.org/877095 Signed-off-by: Z. Liu <zhixu.liu@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/39706 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/beep/beep-1.4.12-r1.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/app-misc/beep/beep-1.4.12-r1.ebuild b/app-misc/beep/beep-1.4.12-r1.ebuild
new file mode 100644
index 000000000000..6615cc9f090a
--- /dev/null
+++ b/app-misc/beep/beep-1.4.12-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit fcaps toolchain-funcs
+
+DESCRIPTION="Advanced PC speaker beeper"
+HOMEPAGE="https://github.com/spkr-beep/beep"
+SRC_URI="https://github.com/spkr-beep/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+
+# Tests require a speaker
+RESTRICT="test"
+
+src_prepare() {
+ default
+
+ cat <<-EOF > local.mk || die
+ CC=$(tc-getCC)
+ CFLAGS=${CFLAGS}
+ CPPFLAGS=${CPPFLAGS}
+ LDFLAGS=${LDFLAGS}
+ EOF
+
+ sed -i \
+ -e "s#-D_FORTIFY_SOURCE=2##g;" \
+ -e '/\-Werror)/d' \
+ GNUmakefile || die
+}
+
+src_install() {
+ dobin beep
+ doman "${PN}.1"
+
+ fperms 0711 /usr/bin/beep
+
+ local DOCS=(
+ CREDITS.md DEVELOPMENT.md INSTALL.md NEWS.md PACKAGING.md PERMISSIONS.md README.md
+ )
+ einstalldocs
+}
+
+pkg_postinst() {
+ FILECAPS=(
+ -m0711 cap_dac_override,cap_sys_tty_config "${EROOT}/usr/bin/beep"
+ )
+
+ elog "Please note that for security reasons, beep will no longer allow"
+ elog "to running w/ SUID or as root under sudo. You will need to give"
+ elog "permissions for the PC speaker device to allow non-root users to"
+ elog "use 'beep' by either:"
+ elog " setfacl -m u:<youruser>:rw /dev/input/by-path/platform-pcspkr-event-spkr"
+ elog "or add yourself to the 'input' group:"
+ elog " usermod -aG input <youruser>"
+ elog "It's preferred to use setfacl with least privilege."
+}