summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBratishkaErik <bratishkaerik@getgoogleoff.me>2022-03-05 22:26:44 +0600
committerJoonas Niilola <juippis@gentoo.org>2022-03-11 16:37:20 +0200
commita6478a354fcad2afb9bd1427d4fd77864e37c22b (patch)
tree7af45bc2c6149fb931ef068a8f5d63bcf0ce5ddb /app-misc
parentmedia-gfx/hydrus: Fix building without the doc flag (diff)
downloadgentoo-a6478a354fcad2afb9bd1427d4fd77864e37c22b.tar.gz
gentoo-a6478a354fcad2afb9bd1427d4fd77864e37c22b.tar.bz2
gentoo-a6478a354fcad2afb9bd1427d4fd77864e37c22b.zip
app-misc/piper: New version 0.6
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/piper/Manifest1
-rw-r--r--app-misc/piper/piper-0.5.1-r2.ebuild8
-rw-r--r--app-misc/piper/piper-0.6.ebuild53
3 files changed, 58 insertions, 4 deletions
diff --git a/app-misc/piper/Manifest b/app-misc/piper/Manifest
index 9a1f22519818..c640a281e4f1 100644
--- a/app-misc/piper/Manifest
+++ b/app-misc/piper/Manifest
@@ -1 +1,2 @@
DIST piper-0.5.1.tar.gz 234944 BLAKE2B 1df33ca6e2d0dae95b34f8e3a98c6829a8f113ae68fb60980ff40374090b9272f86d69103c33fe0a4e1b0ac21a84724e7cabccca4ce8dd23d02f6d56e67d072b SHA512 13368521a9c32b2dc3300b129ed3bb07a6204623fa750f8f75ca31d2a3b60f43ae5f5066ef755814960d4890a489bdfd21b0e1b8f456b3445e0ba35ac06bc877
+DIST piper-0.6.tar.gz 254653 BLAKE2B ea621e556e2ee6a98e334f2e61df70d700a9cb371dcd5bddc690b4a4c97543a6957bc339bddbde2cf91ac3b201d3bd70fe336974f17e36cfdcbb4895257af993 SHA512 9d76cbc5f3a91c68d10355a1b429c05873effcaa80086fb51c7d4a7bdbbb3e0faf42ec8ccad611a15f5c954d3014a8416e4a497c86167c227818771a24d108a0
diff --git a/app-misc/piper/piper-0.5.1-r2.ebuild b/app-misc/piper/piper-0.5.1-r2.ebuild
index 9379797c495b..e72e7068ab4e 100644
--- a/app-misc/piper/piper-0.5.1-r2.ebuild
+++ b/app-misc/piper/piper-0.5.1-r2.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_COMPAT=( python3_{8..10} )
-inherit meson python-single-r1 udev xdg
+inherit meson python-single-r1 xdg
DESCRIPTION="GTK configuration application for libratbag"
HOMEPAGE="https://github.com/libratbag/piper"
diff --git a/app-misc/piper/piper-0.6.ebuild b/app-misc/piper/piper-0.6.ebuild
new file mode 100644
index 000000000000..4069145b9c5c
--- /dev/null
+++ b/app-misc/piper/piper-0.6.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit meson python-single-r1 xdg
+
+DESCRIPTION="GTK configuration application for libratbag"
+HOMEPAGE="https://github.com/libratbag/piper"
+SRC_URI="https://github.com/libratbag/piper/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+"
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/gobject-introspection
+ >=dev-libs/libratbag-0.13
+ gnome-base/librsvg[introspection]
+ x11-libs/gdk-pixbuf[introspection]
+ x11-libs/gtk+:3[introspection]
+ $(python_gen_cond_dep '
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[cairo,${PYTHON_USEDEP}]
+ dev-python/python-evdev[${PYTHON_USEDEP}]
+ dev-python/flake8[${PYTHON_USEDEP}]
+ ')
+"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/libevdev
+ virtual/libudev
+"
+
+src_configure() {
+ python_setup
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ python_optimize
+ python_fix_shebang "${ED}"/usr/bin/
+}