summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2024-11-17 00:09:52 +0100
committerDavid Seifert <soap@gentoo.org>2024-11-17 00:09:52 +0100
commit33d5365a0fc4040370b1bcb5b99c9f02e109fcd9 (patch)
tree6870d9cdd4d288b7d87a49cc3ee6e7625ac04a58 /app-text
parentmedia-video/ffmpeg-chromium: add 133 (diff)
downloadgentoo-33d5365a0fc4040370b1bcb5b99c9f02e109fcd9.tar.gz
gentoo-33d5365a0fc4040370b1bcb5b99c9f02e109fcd9.tar.bz2
gentoo-33d5365a0fc4040370b1bcb5b99c9f02e109fcd9.zip
app-text/tree: drop 2.1.0
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/tree/Manifest1
-rw-r--r--app-text/tree/files/tree.bashcomp34
-rw-r--r--app-text/tree/tree-2.1.0.ebuild31
3 files changed, 0 insertions, 66 deletions
diff --git a/app-text/tree/Manifest b/app-text/tree/Manifest
index f7761a570ad0..229d01ebf26b 100644
--- a/app-text/tree/Manifest
+++ b/app-text/tree/Manifest
@@ -1,2 +1 @@
-DIST unix-tree-2.1.0.tar.bz2 51401 BLAKE2B 89b15df0268c03ba66827c7e6d234d1f5c4f6a5d9788e30bf6859d477b340393acbeec9ad7afc1909fdc7beb81ef7934917206066e0875d9f1662fca170f4127 SHA512 0f3a6ecb450bb3d683804667d4f15aecf9c9765578d47a62e39a8ff69cbe1c2a0a4a922fef3728359060338f4f9cd2de7ab8eb0f992a4c32949278bb47d17edc
DIST unix-tree-2.1.1.tar.bz2 52550 BLAKE2B 0f20009a6c64b07a0742637bf32366b038f5c9bb025755a0aa45edb8c92741dfbff1486179caeeb73cfa8f10de3ed8678b948c7416ee0463e785cf153e808ff0 SHA512 ed34b1d0df049986295e7f5539491acd6134fbe69050ac2634037d700a878b4937700bed777ef0624e2bb0fc8c2815bb5139272ffe575ecc9362b84e0fafc9c2
diff --git a/app-text/tree/files/tree.bashcomp b/app-text/tree/files/tree.bashcomp
deleted file mode 100644
index fed493575ea2..000000000000
--- a/app-text/tree/files/tree.bashcomp
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-# bash command-line completion for tree
-# Author: Aaron Walker <ka0ttic@gentoo.org>
-
-_tree() {
- local cur prev opts
- COMPREPLY=()
- cur="${COMP_WORDS[COMP_CWORD]}"
- prev="${COMP_WORDS[COMP_CWORD-1]}"
- opts="-a -d -l -f -i -q -N -p -u -g -s -D -F -r -t -x -L -A
- -S -n -C -P -I -H -T -R -o --inodes --device --noreport --nolinks
- --dirsfirst --charset --help"
-
- if [[ ${cur} == -* ]] ; then
- COMPREPLY=( $(compgen -W "${opts}" -- "${cur}") )
- return 0
- fi
-
- case "${prev}" in
- -L|-P|-I|-H|-T|--charset|--help)
- ;;
- -o)
- _filedir
- ;;
- *)
- _filedir -d
- ;;
- esac
-}
-complete -o filenames -F _tree tree
-
-# vim: set ft=sh tw=80 sw=4 et :
diff --git a/app-text/tree/tree-2.1.0.ebuild b/app-text/tree/tree-2.1.0.ebuild
deleted file mode 100644
index 2d5b903eee52..000000000000
--- a/app-text/tree/tree-2.1.0.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit toolchain-funcs flag-o-matic bash-completion-r1
-
-DESCRIPTION="Lists directories recursively, and produces an indented listing of files"
-HOMEPAGE="https://mama.indstate.edu/users/ice/tree/ https://gitlab.com/OldManProgrammer/unix-tree"
-SRC_URI="https://gitlab.com/OldManProgrammer/unix-${PN}/-/archive/${PV}/unix-${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos"
-
-S=${WORKDIR}/unix-${P}
-
-src_compile() {
- append-lfs-flags
- emake \
- CC="$(tc-getCC)" \
- CFLAGS="${CFLAGS} ${CPPFLAGS}" \
- LDFLAGS="${LDFLAGS}"
-}
-
-src_install() {
- dobin tree
- doman doc/tree*.1
- einstalldocs
- newbashcomp "${FILESDIR}"/${PN}.bashcomp ${PN}
-}