summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-04-22 12:56:56 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-04-22 18:33:37 +0200
commit67996d65a5de7c2ec48cf2f24adbc5182a7567ef (patch)
treec9429ccaeff672f25ef8409851c20dcec2bbc20a /app-text
parentapp-portage/fetchcommandwrapper: EAPI 7 + Python 3.7 + drop old (diff)
downloadgentoo-67996d65a5de7c2ec48cf2f24adbc5182a7567ef.tar.gz
gentoo-67996d65a5de7c2ec48cf2f24adbc5182a7567ef.tar.bz2
gentoo-67996d65a5de7c2ec48cf2f24adbc5182a7567ef.zip
app-text/libmwaw: EAPI-7 bump
Package-Manager: Portage-2.3.64, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/libmwaw/libmwaw-9999.ebuild41
1 files changed, 22 insertions, 19 deletions
diff --git a/app-text/libmwaw/libmwaw-9999.ebuild b/app-text/libmwaw/libmwaw-9999.ebuild
index 7dde090fa754..cc207bd575ba 100644
--- a/app-text/libmwaw/libmwaw-9999.ebuild
+++ b/app-text/libmwaw/libmwaw-9999.ebuild
@@ -1,32 +1,33 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-EGIT_REPO_URI="git://git.code.sf.net/p/libmwaw/libmwaw"
-[[ ${PV} == 9999 ]] && inherit autotools git-r3
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="https://git.code.sf.net/p/libmwaw/libmwaw"
+ inherit autotools git-r3
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
DESCRIPTION="Library parsing many pre-OSX MAC text formats"
HOMEPAGE="https://sourceforge.net/p/libmwaw/wiki/Home/"
-[[ ${PV} == 9999 ]] || SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
LICENSE="LGPL-2.1"
SLOT="0"
-
-[[ ${PV} == 9999 ]] || \
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-
IUSE="doc static-libs tools"
-RDEPEND="
- dev-libs/librevenge
- sys-libs/zlib
-"
-DEPEND="${RDEPEND}
+BDEPEND="
sys-devel/libtool
virtual/pkgconfig
doc? ( app-doc/doxygen )
"
+DEPEND="
+ dev-libs/librevenge
+ sys-libs/zlib
+"
+RDEPEND="${DEPEND}"
src_prepare() {
default
@@ -35,12 +36,14 @@ src_prepare() {
src_configure() {
# zip is hard enabled as the zlib is dep on the rdeps anyway
- econf \
- --enable-zip \
- --disable-werror \
- $(use_with doc docs) \
- $(use_enable static-libs static) \
+ local myeconfargs=(
+ --enable-zip
+ --disable-werror
+ $(use_with doc docs)
+ $(use_enable static-libs static)
$(use_enable tools)
+ )
+ econf "${myeconfargs[@]}"
}
src_install() {