summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-vim/alternate
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-vim/alternate')
-rw-r--r--app-vim/alternate/Manifest1
-rw-r--r--app-vim/alternate/alternate-2.18.ebuild24
-rw-r--r--app-vim/alternate/files/alternate-2.12-hh-cc-alternation.patch18
-rw-r--r--app-vim/alternate/files/alternate-2.18-hh-cc-alternation.patch18
-rw-r--r--app-vim/alternate/metadata.xml5
5 files changed, 66 insertions, 0 deletions
diff --git a/app-vim/alternate/Manifest b/app-vim/alternate/Manifest
new file mode 100644
index 000000000000..abb5770c1893
--- /dev/null
+++ b/app-vim/alternate/Manifest
@@ -0,0 +1 @@
+DIST alternate-2.18.tar.bz2 7907 SHA256 2367638f93c6ce3681a6ad6d5c83f586cd6598abd9f0b20bf02c740ac0efb59e SHA512 397d39a5c5fd186f32f3e0a1651f9b9f739899ffcfdd344e85117c4bb676d8fb8c668410754fefe8934ff1a57537387d49d115dfa17bdca896e423935840ae3f WHIRLPOOL d7635d1812b311232fcbee42d94ad9a0b86176f789d5f9336eb40d2efe5c1a2f660008b8facf5dbba8c094946a574e6b379dd7262dea4aff278c34b7cbe25ec7
diff --git a/app-vim/alternate/alternate-2.18.ebuild b/app-vim/alternate/alternate-2.18.ebuild
new file mode 100644
index 000000000000..1e113545ad2c
--- /dev/null
+++ b/app-vim/alternate/alternate-2.18.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit vim-plugin eutils
+
+DESCRIPTION="vim plugin: quickly switch between .c and .h files"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=31"
+
+LICENSE="alternate"
+KEYWORDS="alpha amd64 ia64 ~mips ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin provides a new :A command which will switch between a .c
+file and the associated .h file. There is also :AS to split windows and
+:AV to split windows vertiically."
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # fix switching between .cc and .hh files, thanks ciaranm
+ epatch "${FILESDIR}"/${P}-hh-cc-alternation.patch
+}
diff --git a/app-vim/alternate/files/alternate-2.12-hh-cc-alternation.patch b/app-vim/alternate/files/alternate-2.12-hh-cc-alternation.patch
new file mode 100644
index 000000000000..14b314aa0e0c
--- /dev/null
+++ b/app-vim/alternate/files/alternate-2.12-hh-cc-alternation.patch
@@ -0,0 +1,18 @@
+--- a/plugin/a.vim 2005-05-06 22:20:24.000000000 +0100
++++ b/plugin/a.vim 2005-06-20 15:45:45.000000000 +0100
+@@ -57,13 +57,14 @@
+ " Mappings for C and C++
+ call <SID>AddAlternateExtensionMapping('h',"c,cpp,cxx,cc,CC")
+ call <SID>AddAlternateExtensionMapping('H',"C,CPP,CXX,CC")
++call <SID>AddAlternateExtensionMapping('hh',"c,cpp,cxx,cc,CC")
+ call <SID>AddAlternateExtensionMapping('hpp',"cpp,c")
+ call <SID>AddAlternateExtensionMapping('HPP',"CPP,C")
+ call <SID>AddAlternateExtensionMapping('c',"h")
+ call <SID>AddAlternateExtensionMapping('C',"H")
+ call <SID>AddAlternateExtensionMapping('cpp',"h,hpp")
+ call <SID>AddAlternateExtensionMapping('CPP',"H,HPP")
+-call <SID>AddAlternateExtensionMapping('cc',"h")
++call <SID>AddAlternateExtensionMapping('cc',"h,hh")
+ call <SID>AddAlternateExtensionMapping('CC',"H,h")
+ call <SID>AddAlternateExtensionMapping('cxx',"h")
+ call <SID>AddAlternateExtensionMapping('CXX',"H")
diff --git a/app-vim/alternate/files/alternate-2.18-hh-cc-alternation.patch b/app-vim/alternate/files/alternate-2.18-hh-cc-alternation.patch
new file mode 100644
index 000000000000..3ea591e1e2fe
--- /dev/null
+++ b/app-vim/alternate/files/alternate-2.18-hh-cc-alternation.patch
@@ -0,0 +1,18 @@
+--- plugin/a.vim 2005-05-06 22:20:24.000000000 +0100
++++ plugin/a.vim 2005-06-20 15:45:45.000000000 +0100
+@@ -57,13 +57,14 @@
+ " Mappings for C and C++
+ call <SID>AddAlternateExtensionMapping('h',"c,cpp,cxx,cc,CC")
+ call <SID>AddAlternateExtensionMapping('H',"C,CPP,CXX,CC")
++call <SID>AddAlternateExtensionMapping('hh',"c,cpp,cxx,cc,CC")
+ call <SID>AddAlternateExtensionMapping('hpp',"cpp,c")
+ call <SID>AddAlternateExtensionMapping('HPP',"CPP,C")
+ call <SID>AddAlternateExtensionMapping('c',"h")
+ call <SID>AddAlternateExtensionMapping('C',"H")
+ call <SID>AddAlternateExtensionMapping('cpp',"h,hpp")
+ call <SID>AddAlternateExtensionMapping('CPP',"H,HPP")
+-call <SID>AddAlternateExtensionMapping('cc',"h")
++call <SID>AddAlternateExtensionMapping('cc',"h,hh")
+ call <SID>AddAlternateExtensionMapping('CC',"H,h")
+ call <SID>AddAlternateExtensionMapping('cxx',"h")
+ call <SID>AddAlternateExtensionMapping('CXX',"H")
diff --git a/app-vim/alternate/metadata.xml b/app-vim/alternate/metadata.xml
new file mode 100644
index 000000000000..d221a8d4b42c
--- /dev/null
+++ b/app-vim/alternate/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+</pkgmetadata>