summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-10-29 00:48:14 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-10-29 07:57:29 +0100
commit8274919bc4e5d0ec66cb662207bd12433cd9a392 (patch)
treebc405d379a94474f7da1f23078afd075c6f9b65e /app-vim/vim-go/vim-go-1.13.ebuild
parentdev-python/pyasn1-modules: version bump to 0.1.5 (diff)
downloadgentoo-8274919bc4e5d0ec66cb662207bd12433cd9a392.tar.gz
gentoo-8274919bc4e5d0ec66cb662207bd12433cd9a392.tar.bz2
gentoo-8274919bc4e5d0ec66cb662207bd12433cd9a392.zip
app-vim/vim-go: new package.
vim-go is a Go development plugin for Vim. Package-Manager: Portage-2.3.8, Repoman-2.3.3 Bug: https://bugs.gentoo.org/635420
Diffstat (limited to 'app-vim/vim-go/vim-go-1.13.ebuild')
-rw-r--r--app-vim/vim-go/vim-go-1.13.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-vim/vim-go/vim-go-1.13.ebuild b/app-vim/vim-go/vim-go-1.13.ebuild
new file mode 100644
index 000000000000..2cffe300bf04
--- /dev/null
+++ b/app-vim/vim-go/vim-go-1.13.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Go development plugin for Vim"
+HOMEPAGE="https://github.com/fatih/vim-go"
+SRC_URI="https://github.com/fatih/${PN}/archive/v${PV}.zip -> ${P}.zip"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="$PN"
+
+RESTRICT="test"
+
+src_compile() {
+ # safely skip `make test` triggered by `make` as it runs `go get` commands
+ # TODO: see :GoInstallBinaries (https://github.com/fatih/vim-go/blob/master/doc/vim-go.txt)
+ :;
+}