summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2019-10-03 14:34:29 +0200
committerTupone Alfredo <tupone@gentoo.org>2019-10-03 14:34:29 +0200
commit10b21a9f0be402a67a16dedd4c0474681effd4f0 (patch)
treeffbd50f0f63ba27526293a83265509b52e57444c /dev-ada/gnat-suite-bin/gnat-suite-bin-2017.ebuild
parentapp-i18n/skk-jisyo: install docs (diff)
downloadgentoo-10b21a9f0be402a67a16dedd4c0474681effd4f0.tar.gz
gentoo-10b21a9f0be402a67a16dedd4c0474681effd4f0.tar.bz2
gentoo-10b21a9f0be402a67a16dedd4c0474681effd4f0.zip
dev-ada/gnat-suite-bin: Add gps suite binary and compiler
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ada/gnat-suite-bin/gnat-suite-bin-2017.ebuild')
-rw-r--r--dev-ada/gnat-suite-bin/gnat-suite-bin-2017.ebuild106
1 files changed, 106 insertions, 0 deletions
diff --git a/dev-ada/gnat-suite-bin/gnat-suite-bin-2017.ebuild b/dev-ada/gnat-suite-bin/gnat-suite-bin-2017.ebuild
new file mode 100644
index 000000000000..a37e17c0d991
--- /dev/null
+++ b/dev-ada/gnat-suite-bin/gnat-suite-bin-2017.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+MYP=gnat-gpl-${PV}
+DESCRIPTION="GNAT Ada suite"
+HOMEPAGE="http://libre.adacore.com/"
+SRC_URI="http://mirrors.cdn.adacore.com/art/591c6d80c7a447af2deed1d7
+ -> ${MYP}-x86_64-linux-bin.tar.gz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ sys-devel/binutils
+ sys-devel/gdb"
+
+S="${WORKDIR}"/${MYP}-x86_64-linux-bin
+
+PREFIX=/opt/${P}
+
+src_prepare() {
+ default
+ rm Makefile
+ cd share/examples/gnat
+ cat header.xml \
+ full_project/full.xml \
+ options/options.xml \
+ other_languages/cpp_main/cpp_main.xml \
+ other_languages/cpp_pragmas/cpp_pragmas.xml \
+ other_languages/import_from_c/import_from_c.xml \
+ plugins/plugins.xml \
+ stream_io/stream_io.xml \
+ simple_project/simple_project.xml \
+ starter/starter.xml \
+ xml_stream/xml_stream.xml \
+ containers/anagram/anagram.xml \
+ containers/genealogy/genealogy.xml \
+ containers/hash/hash.xml \
+ containers/library/library.xml \
+ containers/shapes/shapes.xml \
+ containers/spellcheck/spellcheck.xml \
+ containers/wordcount/wordcount.xml \
+ containers/wordfreq/wordfreq.xml \
+ oo_interfaces/oo_interfaces.xml \
+ oo_airline/oo_airline.xml \
+ altivec/altivec.xml \
+ footer.xml \
+ > gnat-examples.xml \
+ || die
+ sed -i \
+ -e "s:PREFIX:${PREFIX}:" \
+ gnat-examples.xml || die
+ cd ../../..
+
+ # Remove objects from binutils
+ cd bin
+ rm addr2line ar c++filt gprof ld.* nm obj* r* s* || die
+ cd ..
+ rm share/doc/gnat/info/{as,bfd,binutils,ld}.info || die
+
+ # Remove objects from gdb
+ cd bin
+ rm gdb gdbserver gcore || die
+ cd ..
+ rm -r include/gdb || die
+ rm lib*/libinproctrace.so || die
+ rm -r share/gdb-* || die
+ rm share/doc/gnat/info/gdb.info || die
+
+ basever=6.3.1
+ machine=x86_64-pc-linux-gnu
+ rm libexec//gcc/${machine}/${basever}/ld || die
+}
+
+src_install() {
+ into ${PREFIX}
+ dobin bin/*
+ insinto ${PREFIX}
+ doins -r etc include lib* share
+ insinto ${PREFIX}/share/gps/plug-ins
+ doins share/examples/gnat/gnat-examples.xml
+ fperms 755 ${PREFIX}/libexec/gcc/${machine}/${basever}/cc1 || die
+ fperms 755 ${PREFIX}/libexec/gcc/${machine}/${basever}/cc1plus || die
+ fperms 755 ${PREFIX}/libexec/gcc/${machine}/${basever}/collect2 || die
+ fperms 755 ${PREFIX}/libexec/gcc/${machine}/${basever}/gnat1 || die
+ fperms 755 ${PREFIX}/libexec/gcc/${machine}/${basever}/liblto_plugin.so.0.0.0 || die
+ fperms 755 ${PREFIX}/libexec/gcc/${machine}/${basever}/lto1 || die
+ fperms 755 ${PREFIX}/libexec/gcc/${machine}/${basever}/lto-wrapper || die
+ fperms 755 ${PREFIX}/libexec/gprbuild/gprbind || die
+ fperms 755 ${PREFIX}/libexec/gprbuild/gprlib || die
+}
+
+pkg_postinst () {
+ einfo "GNAT GPL is now installed. To launch it, you must put"
+ einfo " ${PREFIX}/bin"
+ einfo "in front of your PATH environment variable. The following"
+ einfo "commands enable you to do this:"
+ einfo " PATH=${PREFIX}/bin:\$PATH; export PATH (Bourne shell)"
+ einfo " setenv PATH ${PREFIX}/bin:\$PATH (C shell)"
+ einfo " Thank you for installing GNAT GPL Edition"
+}