summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2025-01-02 13:21:01 +0100
committerAlfredo Tupone <tupone@gentoo.org>2025-01-02 13:21:16 +0100
commitbeb9ab001f750aff9f8d4168b6a46895da30ae6c (patch)
treeb8055018ef9750470dafe5e7589126e765a109e1 /dev-ada
parentdev-ada/templates-parser: does not build with gnat_2021 (diff)
downloadgentoo-beb9ab001f750aff9f8d4168b6a46895da30ae6c.tar.gz
gentoo-beb9ab001f750aff9f8d4168b6a46895da30ae6c.tar.bz2
gentoo-beb9ab001f750aff9f8d4168b6a46895da30ae6c.zip
dev-ada/spawn: add 25.0.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ada')
-rw-r--r--dev-ada/spawn/Manifest1
-rw-r--r--dev-ada/spawn/spawn-25.0.0.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/dev-ada/spawn/Manifest b/dev-ada/spawn/Manifest
index 27d233735b9b..c8c0f406b546 100644
--- a/dev-ada/spawn/Manifest
+++ b/dev-ada/spawn/Manifest
@@ -1 +1,2 @@
DIST spawn-24.0.0.tar.gz 66727 BLAKE2B 12da7485b27ff75ce75efbbe4e9c71542faf2c283f843cc903530b9e8829f86e3ea1aff73f8f9efb80fd9924c695039456f3b63ff6d635161ed8b33daeb2da88 SHA512 948bcaa7963d79f7a42fe05c80586bce669b7ff01bb756c087f237b35892956d2ababc274e594e9bda82a8c70fbb62c9ca199161176c87ed3ff42f9e7bc78ea9
+DIST spawn-25.0.0.tar.gz 66730 BLAKE2B 45790fcce26594b583eea5cfa123dbd19449d9a38c9fa5f205b549b04f50686ed32609d7b63726815b8ba950e3f61b81f919caaed89d5baa1273e78cff27c1a5 SHA512 429442b1d308b552516bc872508f9d735f0f24acce7c7b705caa54837f3a2eadb7555cad49dbdf01872faf7d838d438b6b542d2196f50f8012ffc8faad4d6f9d
diff --git a/dev-ada/spawn/spawn-25.0.0.ebuild b/dev-ada/spawn/spawn-25.0.0.ebuild
new file mode 100644
index 000000000000..023d363a4087
--- /dev/null
+++ b/dev-ada/spawn/spawn-25.0.0.ebuild
@@ -0,0 +1,83 @@
+# Copyright 2021-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ADA_COMPAT=( gnat_2021 gcc_12 gcc_13 )
+inherit ada multiprocessing
+
+DESCRIPTION="Simple API to spawn processes"
+HOMEPAGE="https://github.com/AdaCore/spawn"
+SRC_URI="https://github.com/AdaCore/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3 gcc-runtime-library-exception-3.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+shared static-libs static-pic"
+REQUIRED_USE="|| ( shared static-libs static-pic )
+ ${ADA_REQUIRED_USE}"
+
+RDEPEND="${ADA_DEPS}"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-ada/gprbuild[${ADA_USEDEP}]"
+
+src_compile() {
+ build () {
+ gprbuild -p -j$(makeopts_jobs) -XBUILD=production -v \
+ -XLIBRARY_TYPE=$1 \
+ gnat/spawn.gpr -cargs:C ${CFLAGS} -cargs:Ada ${ADAFLAGS} || die
+ }
+ if use shared; then
+ build relocatable
+ fi
+ if use static-libs; then
+ build static
+ fi
+ if use static-pic; then
+ build static-pic
+ fi
+}
+
+src_test() {
+ build () {
+ GPR_PROJECT_PATH=gnat \
+ gprbuild -p -j$(makeopts_jobs) -XBUILD=production -v \
+ -XLIBRARY_TYPE=$1 gnat/tests/spawn_tests.gpr \
+ -cargs:C ${CFLAGS} -cargs:Ada ${ADAFLAGS} \
+ || die
+ }
+ if use shared; then
+ build relocatable
+ elif use static-libs; then
+ build static
+ elif use static-pic; then
+ build static-pic
+ fi
+ .obj/spawn_test/spawn_test || die
+ .obj/spawn_test/spawn_unexpected || die
+ .obj/spawn_test/wait_all || die
+ .obj/spawn_test/spawn_bad_exe || die
+ .obj/spawn_test/spawn_kill || die
+ .obj/spawn_test/spawn_stty || die
+}
+
+src_install() {
+ build() {
+ gprinstall --prefix=/usr --sources-subdir="${D}"/usr/include/spawn \
+ -XLIBRARY_TYPE=$1 \
+ --lib-subdir="${D}"/usr/$(get_libdir)/spawn \
+ --project-subdir="${D}"/usr/share/gpr \
+ --link-lib-subdir="${D}"/usr/$(get_libdir)/ -p \
+ -P gnat/spawn.gpr || die
+ }
+ if use shared; then
+ build relocatable
+ fi
+ if use static-libs; then
+ build static
+ fi
+ if use static-pic; then
+ build static-pic
+ fi
+}