summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLinuxUserGD <hugegameartgd@gmail.com>2024-01-24 22:38:52 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-25 15:15:53 +0100
commit5e0b53de8ff9ebd4699129016798a30afd1a3bd8 (patch)
treead0d80607860843a0ccc9acd56bf7a42a721f2d3 /dev-build/icmake
parentwww-client/firefox: Stabilize 115.7.0 arm64, #922883 (diff)
downloadgentoo-5e0b53de8ff9ebd4699129016798a30afd1a3bd8.tar.gz
gentoo-5e0b53de8ff9ebd4699129016798a30afd1a3bd8.tar.bz2
gentoo-5e0b53de8ff9ebd4699129016798a30afd1a3bd8.zip
Move {dev-util → dev-build}/icmake
Signed-off-by: LinuxUserGD <hugegameartgd@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/34998 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-build/icmake')
-rw-r--r--dev-build/icmake/Manifest1
-rw-r--r--dev-build/icmake/files/icmake-9.00.00-ar.patch32
-rw-r--r--dev-build/icmake/files/icmake-9.02.02-verbose-build.patch11
-rw-r--r--dev-build/icmake/files/icmake-9.03.01-compressed-docs.patch32
-rw-r--r--dev-build/icmake/icmake-9.03.01.ebuild47
-rw-r--r--dev-build/icmake/metadata.xml8
6 files changed, 131 insertions, 0 deletions
diff --git a/dev-build/icmake/Manifest b/dev-build/icmake/Manifest
new file mode 100644
index 000000000000..bf7b36e3c2ca
--- /dev/null
+++ b/dev-build/icmake/Manifest
@@ -0,0 +1 @@
+DIST icmake-9.03.01.tar.gz 393488 BLAKE2B 43bac6944aa816e077a55264064abcb55ff3525842ab923712997248ef198a934fa434352fef3484a8ed0f887a89d9151b8e56ef7c601435d26d1644438b2b55 SHA512 2e6228c3bffa7fa145fd3743b1220d96b5730350718b91be96600cb24317e17aa5138282fe2f603d00dadd57d7a832ecff21a570eab0c21426f94d3208a61184
diff --git a/dev-build/icmake/files/icmake-9.00.00-ar.patch b/dev-build/icmake/files/icmake-9.00.00-ar.patch
new file mode 100644
index 000000000000..0eff669f8e39
--- /dev/null
+++ b/dev-build/icmake/files/icmake-9.00.00-ar.patch
@@ -0,0 +1,32 @@
+--- icmake/bootstrap/flags
++++ icmake/bootstrap/flags
+@@ -14,3 +14,7 @@
+ if [ "${CC}" == "" ] ; then
+ CC="gcc"
+ fi
++
++if [ "${AR}" == "" ] ; then
++ CC="ar"
++fi
+--- icmake/bootstrap/functions
++++ icmake/bootstrap/functions
+@@ -35,7 +35,7 @@
+
+ echo -n .
+
+- try ar crs ../tmp/lib${program}.a */*.o
++ try ${AR} crs ../tmp/lib${program}.a */*.o
+
+ echo -n .
+
+--- icmake/rss/icm_bootstrap
++++ icmake/rss/icm_bootstrap
+@@ -8,7 +8,7 @@
+ echo -n .
+ try ${CC} -c ${CFLAGS} *.c
+ echo -n .
+-try ar rs ../tmp/libicrss.a *.o
++try ${AR} rs ../tmp/libicrss.a *.o
+ echo -n .
+ rm *.o
+ echo .
diff --git a/dev-build/icmake/files/icmake-9.02.02-verbose-build.patch b/dev-build/icmake/files/icmake-9.02.02-verbose-build.patch
new file mode 100644
index 000000000000..dde1af395152
--- /dev/null
+++ b/dev-build/icmake/files/icmake-9.02.02-verbose-build.patch
@@ -0,0 +1,11 @@
+--- icmake/bootstrap/functions
++++ icmake/bootstrap/functions
+@@ -2,7 +2,7 @@
+
+ try()
+ {
+- # echo $*
++ echo $*
+ $* || exit 1
+ }
+
diff --git a/dev-build/icmake/files/icmake-9.03.01-compressed-docs.patch b/dev-build/icmake/files/icmake-9.03.01-compressed-docs.patch
new file mode 100644
index 000000000000..a8bb04e3102e
--- /dev/null
+++ b/dev-build/icmake/files/icmake-9.03.01-compressed-docs.patch
@@ -0,0 +1,32 @@
+diff --git a/icm_bootstrap b/icm_bootstrap
+index 9a80252..78ece4f 100755
+--- a/icm_bootstrap
++++ b/icm_bootstrap
+@@ -45,11 +45,11 @@ cd doc
+
+ echo man-pages to tmp/${MANDIR}/man1 and .../man7
+ for x in *.1 ; do
+- gzip -9cn $x > ../tmp/${MANDIR}/man1/$x.gz || exit 1
++ cp $x ../tmp/${MANDIR}/man1/$x || exit 1
+ done
+
+ for x in *.7 ; do
+- gzip -9cn $x > ../tmp/${MANDIR}/man7/$x.gz || exit 1
++ cp $x ../tmp/${MANDIR}/man7/$x || exit 1
+ done
+
+ echo documentation to tmp/${DOCDIR} and tmp/${DOCDOCDIR}
+@@ -58,11 +58,11 @@ echo documentation to tmp/${DOCDIR} and tmp/${DOCDOCDIR}
+ # gzip -9cn $x > ../tmp/${DOCDOCDIR}/$x.gz || exit 1
+ #done
+
+-gzip -9cn icmake.ps > ../tmp/${DOCDOCDIR}/icmake.ps.gz || exit 1
++cp icmake.ps ../tmp/${DOCDOCDIR}/icmake.ps || exit 1
+
+ cd ..
+
+-gzip -9cn changelog > tmp/${DOCDIR}/changelog.gz || exit 1
++cp changelog tmp/${DOCDIR}/changelog || exit 1
+
+ try cp -r examples tmp/${DOCDOCDIR}
+
diff --git a/dev-build/icmake/icmake-9.03.01.ebuild b/dev-build/icmake/icmake-9.03.01.ebuild
new file mode 100644
index 000000000000..f6e27f88a3f8
--- /dev/null
+++ b/dev-build/icmake/icmake-9.03.01.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="Hybrid between a make utility and a shell scripting language"
+HOMEPAGE="https://fbb-git.gitlab.io/icmake/ https://gitlab.com/fbb-git/icmake"
+SRC_URI="https://gitlab.com/fbb-git/${PN}/-/archive/${PV}/${P}.tar.gz"
+S="${WORKDIR}/${P}/${PN}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-9.00.00-ar.patch
+ "${FILESDIR}"/${PN}-9.02.02-verbose-build.patch
+ "${FILESDIR}"/${PN}-9.03.01-compressed-docs.patch
+)
+
+src_prepare() {
+ default
+
+ sed -e "/^#define LIBDIR/s/lib/$(get_libdir)/" \
+ -e "/^#define DOCDIR/s/${PN}/${PF}/" \
+ -e "/^#define DOCDOCDIR/s/${PN}-doc/${PF}/" \
+ -i INSTALL.im || die
+
+ # fix build issues (bug #589896)
+ append-cflags -std=gnu99
+
+ tc-export AR CC
+}
+
+src_configure() {
+ ./icm_prepare "${EPREFIX}" || die
+}
+
+src_compile() {
+ ./icm_bootstrap "${EPREFIX}" || die
+}
+
+src_install() {
+ ./icm_install all "${ED}" || die
+}
diff --git a/dev-build/icmake/metadata.xml b/dev-build/icmake/metadata.xml
new file mode 100644
index 000000000000..cb2d5608ccb6
--- /dev/null
+++ b/dev-build/icmake/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="gitlab">fbb-git/icmake</remote-id>
+ </upstream>
+</pkgmetadata>