summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Parborg <sebastian@blender.org>2024-12-17 18:31:34 +0100
committerSam James <sam@gentoo.org>2024-12-22 01:27:54 +0000
commit4b6bedcedfc6a2e7b8c59262dea3d3e42f248427 (patch)
tree2119199b2e530176632f5434d611b819dd34e679 /dev-cpp/pystring
parentapp-admin/ansible-core: drop 2.15.8-r1 (diff)
downloadgentoo-4b6bedcedfc6a2e7b8c59262dea3d3e42f248427.tar.gz
gentoo-4b6bedcedfc6a2e7b8c59262dea3d3e42f248427.tar.bz2
gentoo-4b6bedcedfc6a2e7b8c59262dea3d3e42f248427.zip
dev-cpp/pystring: Bump to 1.1.4
Closes: https://bugs.gentoo.org/943179 Signed-off-by: Sebastian Parborg <darkdefende@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/39761 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp/pystring')
-rw-r--r--dev-cpp/pystring/Manifest1
-rw-r--r--dev-cpp/pystring/files/install_header_file.patch15
-rw-r--r--dev-cpp/pystring/pystring-1.1.4.ebuild27
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-cpp/pystring/Manifest b/dev-cpp/pystring/Manifest
index eb3773a17b36..b9b2b58cb8f5 100644
--- a/dev-cpp/pystring/Manifest
+++ b/dev-cpp/pystring/Manifest
@@ -1 +1,2 @@
DIST pystring-1.1.3.tar.gz 18364 BLAKE2B caab1a3b1dc688ad6ecbb32e5e8139bb883a88b78ce8a021229924d57376e94b17d89277e2fccf4f7ec478c81ee9259c5e56848f4388c44b2eab9cfb841bcfb8 SHA512 a46bb2e96d6eb351a4a8097cde46ac2877d28e88f9e57e0ac36c42e8fc8543517c4be70306a01e2f88a891fc53c612494aeb37f47a200d94b8e1b050ed16eff6
+DIST pystring-1.1.4.tar.gz 19184 BLAKE2B 299e6feb10e2f12fa1e92fd1a7309b482769b4d0edea65f5f4bac06c6ae318d3464cf8acc2d6a899c28eb9073a396402b6d28e0950b51ac7f214da1a0a7ca521 SHA512 9c0460fea67885492f9b0d29a9ba312d960fd5e43577cdcfd47faf04397ff4b7e456ed68f1948b923d2f63f9922d576b93e4ca1a27376bcb6d29c683828acb01
diff --git a/dev-cpp/pystring/files/install_header_file.patch b/dev-cpp/pystring/files/install_header_file.patch
new file mode 100644
index 000000000000..634a1efc050b
--- /dev/null
+++ b/dev-cpp/pystring/files/install_header_file.patch
@@ -0,0 +1,15 @@
+Modify Cmake so that it installs the header file
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index fed418f..0354c36 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -19,4 +19,8 @@ include(GNUInstallDirs)
+ install(TARGETS pystring
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ )
++install (FILES pystring.h
++ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/${PROJECT_NAME}
++ COMPONENT developer
++)
+
diff --git a/dev-cpp/pystring/pystring-1.1.4.ebuild b/dev-cpp/pystring/pystring-1.1.4.ebuild
new file mode 100644
index 000000000000..749a5769169b
--- /dev/null
+++ b/dev-cpp/pystring/pystring-1.1.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="C++ functions matching the interface and behavior of python string methods"
+HOMEPAGE="https://github.com/imageworks/pystring"
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/imageworks/pystring.git"
+else
+ SRC_URI="https://github.com/imageworks/pystring/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+BDEPEND="dev-build/libtool"
+
+PATCHES=(
+ # This release doesn't install the header file.
+ "${FILESDIR}/install_header_file.patch"
+)