summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-go/go-tools/go-tools-9999.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-go/go-tools/go-tools-9999.ebuild')
-rw-r--r--dev-go/go-tools/go-tools-9999.ebuild90
1 files changed, 90 insertions, 0 deletions
diff --git a/dev-go/go-tools/go-tools-9999.ebuild b/dev-go/go-tools/go-tools-9999.ebuild
new file mode 100644
index 000000000000..3e1bc873aed2
--- /dev/null
+++ b/dev-go/go-tools/go-tools-9999.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+EGO_PN="golang.org/x/tools/..."
+EGO_SRC="golang.org/x/tools"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ EGIT_COMMIT="ac303766f5f240c1796eeea3dc9bf34f1261aa35"
+ ARCHIVE_URI="https://github.com/golang/tools/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="Go Tools"
+HOMEPAGE="https://godoc.org/golang.org/x/tools"
+SRC_URI="${ARCHIVE_URI}
+ http://golang.org/favicon.ico -> go-favicon.ico"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+DEPEND="dev-go/go-net:="
+RDEPEND=""
+
+src_prepare() {
+ # disable broken tests
+ sed -e 's:TestWeb(:_\0:' \
+ -i src/${EGO_SRC}/cmd/godoc/godoc_test.go || die
+ sed -e 's:TestVet(:_\0:' \
+ -i src/${EGO_SRC}/cmd/vet/vet_test.go || die
+ sed -e 's:TestImport(:_\0:' \
+ -i src/${EGO_SRC}/go/gcimporter/gcimporter_test.go || die
+ sed -e 's:TestImportStdLib(:_\0:' \
+ -i src/${EGO_SRC}/go/importer/import_test.go || die
+ sed -e 's:TestStdlib(:_\0:' \
+ -i src/${EGO_SRC}/go/loader/stdlib_test.go || die
+ sed -e 's:TestStdlib(:_\0:' \
+ -i src/${EGO_SRC}/go/ssa/stdlib_test.go || die
+ sed -e 's:TestGorootTest(:_\0:' \
+ -e 's:TestFoo(:_\0:' \
+ -e 's:TestTestmainPackage(:_\0:' \
+ -i src/${EGO_SRC}/go/ssa/interp/interp_test.go || die
+ sed -e 's:TestBar(:_\0:' \
+ -e 's:TestFoo(:_\0:' \
+ -i src/${EGO_SRC}/go/ssa/interp/testdata/a_test.go || die
+ sed -e 's:TestCheck(:_\0:' \
+ -i src/${EGO_SRC}/go/types/check_test.go || die
+ sed -e 's:TestStdlib(:_\0:' \
+ -e 's:TestStdFixed(:_\0:' \
+ -e 's:TestStdKen(:_\0:' \
+ -i src/${EGO_SRC}/go/types/stdlib_test.go || die
+ sed -e 's:TestRepoRootForImportPath(:_\0:' \
+ -i src/${EGO_SRC}/go/vcs/vcs_test.go || die
+ sed -e 's:TestStdlib(:_\0:' \
+ -i src/${EGO_SRC}/refactor/lexical/lexical_test.go || die
+
+ # Add favicon to the godoc web interface (bug 551030)
+ cp "${DISTDIR}"/go-favicon.ico "src/${EGO_SRC}/godoc/static/favicon.ico" ||
+ die
+ sed -e 's:"example.html",:\0\n\t"favicon.ico",:' \
+ -i src/${EGO_SRC}/godoc/static/makestatic.go || die
+ sed -e 's:<link type="text/css":<link rel="icon" type="image/png" href="/lib/godoc/favicon.ico">\n\0:' \
+ -i src/${EGO_SRC}/godoc/static/godoc.html || die
+}
+
+src_compile() {
+ # Generate static.go with favicon included
+ pushd src/golang.org/x/tools/godoc/static >/dev/null || die
+ go run makestatic.go || die
+ popd >/dev/null
+
+ golang-build_src_compile
+}
+
+src_install() {
+ # Create a writable GOROOT in order to avoid sandbox violations.
+ cp -sR "$(go env GOROOT)" "${T}/goroot" || die
+
+ GOROOT="${T}/goroot" golang-build_src_install
+ dobin bin/* "${T}/goroot/bin/godoc"
+
+ exeinto "$(go env GOTOOLDIR)"
+ exeopts -m0755 -p # preserve timestamps for bug 551486
+ doexe "${T}/goroot/pkg/tool/$(go env GOOS)_$(go env GOARCH)/cover"
+ doexe "${T}/goroot/pkg/tool/$(go env GOOS)_$(go env GOARCH)/vet"
+}