summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-08-19 18:55:14 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-20 07:34:45 +0100
commitbd94e31932f715c0893ffd0f149ea6d7ee880c30 (patch)
treeecd0757579a4dae445a9a6a4441a193395a264c9 /dev-haskell/optparse-simple/optparse-simple-0.1.1.3.ebuild
parentapp-admin/calamares: Remove 3.2.20 (diff)
downloadgentoo-bd94e31932f715c0893ffd0f149ea6d7ee880c30.tar.gz
gentoo-bd94e31932f715c0893ffd0f149ea6d7ee880c30.tar.bz2
gentoo-bd94e31932f715c0893ffd0f149ea6d7ee880c30.zip
dev-haskell/optparse-simple: bump up to 0.1.1.3
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Jack Todaro <solpeth@posteo.org> Closes: https://github.com/gentoo/gentoo/pull/17170 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/optparse-simple/optparse-simple-0.1.1.3.ebuild')
-rw-r--r--dev-haskell/optparse-simple/optparse-simple-0.1.1.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-haskell/optparse-simple/optparse-simple-0.1.1.3.ebuild b/dev-haskell/optparse-simple/optparse-simple-0.1.1.3.ebuild
new file mode 100644
index 000000000000..a1356dfda28f
--- /dev/null
+++ b/dev-haskell/optparse-simple/optparse-simple-0.1.1.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Simple interface to optparse-applicative"
+HOMEPAGE="https://github.com/fpco/optparse-simple#readme"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="build-example"
+
+RDEPEND=">=dev-haskell/githash-0.1.3.0:=[profile?]
+ dev-haskell/optparse-applicative:=[profile?]
+ >=dev-lang/ghc-8.0.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.24.2.0
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag build-example build-example)
+}