summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/echo2
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/echo2')
-rw-r--r--dev-java/echo2/Manifest1
-rw-r--r--dev-java/echo2/echo2-2.1.1.ebuild50
-rw-r--r--dev-java/echo2/metadata.xml5
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-java/echo2/Manifest b/dev-java/echo2/Manifest
new file mode 100644
index 000000000000..a5903c7ac382
--- /dev/null
+++ b/dev-java/echo2/Manifest
@@ -0,0 +1 @@
+DIST NextApp_Echo2-2.1.1.tgz 5372814 SHA256 73c0325d019a7df92270c0f3eebef07c2a4fa42a58e588d3bb2cfbd7c1869ce2 SHA512 bad6d9a6411c6a6fe24edbd88960a5e1179f65e95a26e51610eb0b601e3941dcc82b052a385c6fd429291c524bb722a081f39bf3704b7b403ad98582c8273f26 WHIRLPOOL dac80215f7c2d33ab790b9a5a56b9f2b360e42942676faec58061f55cada7e9b530bc6bea24188b9cb6d15638898705e4dffd54c45e757d97d4e272c292530f6
diff --git a/dev-java/echo2/echo2-2.1.1.ebuild b/dev-java/echo2/echo2-2.1.1.ebuild
new file mode 100644
index 000000000000..26e55743f4ba
--- /dev/null
+++ b/dev-java/echo2/echo2-2.1.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+JAVA_PKG_IUSE="doc source"
+inherit java-pkg-2 java-ant-2
+
+MY_PN="NextApp_Echo2"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Echo2 is the next-generation of the Echo Web Framework"
+HOMEPAGE="http://www.nextapp.com/platform/echo2/echo/"
+SRC_URI="http://download.nextapp.com/downloads/echo2/${PV}/${MY_PN}.tgz -> ${MY_P}.tgz"
+
+LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 )"
+SLOT="2.1"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+COMMON_DEP="java-virtuals/servlet-api:2.4"
+
+DEPEND=">=virtual/jdk-1.4
+ ${COMMON_DEP}"
+
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+
+S=${WORKDIR}/${MY_PN}/
+
+java_prepare() {
+ rm -rfv BinaryLibraries || die
+ echo "servlet.lib.jar=$(java-pkg_getjars servlet-api-2.4)" >> SourceCode/ant.properties || die
+}
+
+src_compile() {
+ cd SourceCode || die
+ eant dist $(use_doc doc.public)
+}
+
+src_install() {
+ java-pkg_dojar SourceCode/dist/lib/*.jar
+ use doc && {
+ cp Documentation/api/public/*.html SourceCode/javadoc/public
+ java-pkg_dojavadoc SourceCode/javadoc/public
+ }
+ use source && java-pkg_dosrc SourceCode/src
+ dodoc ReadMe.txt || die "dodoc failed"
+}
diff --git a/dev-java/echo2/metadata.xml b/dev-java/echo2/metadata.xml
new file mode 100644
index 000000000000..7303cef96964
--- /dev/null
+++ b/dev-java/echo2/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+</pkgmetadata>