summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-07-13 12:49:46 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-07-24 19:06:38 +0200
commitd9e3e78d64db5104c6c437e7529c672d40617fff (patch)
tree5c9fadf79e0b2e31c91ddd3727da4634ce960c78 /dev-java/fastinfoset
parentdev-java/jaxb-stax-ex: drop 2.1.0 (diff)
downloadgentoo-d9e3e78d64db5104c6c437e7529c672d40617fff.tar.gz
gentoo-d9e3e78d64db5104c6c437e7529c672d40617fff.tar.bz2
gentoo-d9e3e78d64db5104c6c437e7529c672d40617fff.zip
dev-java/fastinfoset: java 11 for module-info
Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-java/fastinfoset')
-rw-r--r--dev-java/fastinfoset/fastinfoset-2.1.0-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-java/fastinfoset/fastinfoset-2.1.0-r1.ebuild b/dev-java/fastinfoset/fastinfoset-2.1.0-r1.ebuild
new file mode 100644
index 000000000000..7f4e952e82bf
--- /dev/null
+++ b/dev-java/fastinfoset/fastinfoset-2.1.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri https://github.com/eclipse-ee4j/jaxb-fi/archive/2.1.0.tar.gz --slot 0 --keywords "~amd64 ~ppc64 ~x86" --ebuild fastinfoset-2.1.0.ebuild
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source test"
+MAVEN_ID="com.sun.xml.fastinfoset:FastInfoset:2.1.0"
+JAVA_TESTING_FRAMEWORKS="junit-4"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Open Source implementation of the Fast Infoset Standard for Binary XML"
+HOMEPAGE="https://projects.eclipse.org/projects/ee4j.jaxb-impl/FastInfoset"
+SRC_URI="https://github.com/eclipse-ee4j/jaxb-fi/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 EPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+DEPEND="
+ >=virtual/jdk-11:*
+"
+
+RDEPEND="
+ >=virtual/jre-1.8:*
+"
+
+DOCS=( ../{CONTRIBUTING,NOTICE,README}.md )
+HTML_DOCS=( docs/{index,ReleaseNotes}.html )
+
+S="${WORKDIR}/jaxb-fi-${PV}/${PN}"
+
+JAVA_SRC_DIR="src/main/java"
+JAVA_RESOURCE_DIRS="src/main/resources"
+
+JAVA_TEST_GENTOO_CLASSPATH="junit-4"
+JAVA_TEST_SRC_DIR="src/test/java"
+JAVA_TEST_RESOURCE_DIRS="src/test/resources"