summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/glassfish-persistence
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/glassfish-persistence')
-rw-r--r--dev-java/glassfish-persistence/Manifest1
-rw-r--r--dev-java/glassfish-persistence/files/glassfish-persistence-1.0-python2.7-sax-parser.patch11
-rw-r--r--dev-java/glassfish-persistence/glassfish-persistence-1.0-r1.ebuild39
-rw-r--r--dev-java/glassfish-persistence/metadata.xml8
4 files changed, 59 insertions, 0 deletions
diff --git a/dev-java/glassfish-persistence/Manifest b/dev-java/glassfish-persistence/Manifest
new file mode 100644
index 000000000000..51b875dd4f65
--- /dev/null
+++ b/dev-java/glassfish-persistence/Manifest
@@ -0,0 +1 @@
+DIST glassfish-9_0-b48-src.zip 35162972 SHA256 05e49f43ede3f272934fbe0d67f3ac2474bcf4695935a7af812517aab88e0c49 SHA512 512ccd1c89a1bbd88ca1e45b1e60693bd3c4a6c6ffa19376febb786eb73556f27bc0ce4f0e760d6d80b0711206f6701e7c7da70ef3a5e0084ad0482246506a48 WHIRLPOOL 3b4524497216aebbc1d9f6544d50ead27aa6af2ea9e5364e0323c60d24327db28057db778f294ee7483dfc98142c595ccec5a3e8d147eb8942cbe545ae6f98b9
diff --git a/dev-java/glassfish-persistence/files/glassfish-persistence-1.0-python2.7-sax-parser.patch b/dev-java/glassfish-persistence/files/glassfish-persistence-1.0-python2.7-sax-parser.patch
new file mode 100644
index 000000000000..51b1e8af9429
--- /dev/null
+++ b/dev-java/glassfish-persistence/files/glassfish-persistence-1.0-python2.7-sax-parser.patch
@@ -0,0 +1,11 @@
+--- glassfish/bootstrap/build.xml
++++ glassfish/bootstrap/build.xml
+@@ -23,7 +23,7 @@
+ -->
+
+ <!DOCTYPE project [
+- <!ENTITY glassfish SYSTEM "file:./glassfish.xml">
++ <!ENTITY glassfish SYSTEM "file:glassfish.xml">
+ ]>
+
+ <project name="Top Level Build" default="all" basedir=".">
diff --git a/dev-java/glassfish-persistence/glassfish-persistence-1.0-r1.ebuild b/dev-java/glassfish-persistence/glassfish-persistence-1.0-r1.ebuild
new file mode 100644
index 000000000000..958d4759b77a
--- /dev/null
+++ b/dev-java/glassfish-persistence/glassfish-persistence-1.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Glassfish implementation of persistence API"
+HOMEPAGE="https://glassfish.java.net/"
+SRC_URI="http://download.java.net/javaee5/fcs_branch/promoted/source/glassfish-9_0-b48-src.zip"
+
+LICENSE="CDDL"
+SLOT="0"
+KEYWORDS="amd64 x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="
+ >=virtual/jre-1.5"
+DEPEND="
+ >=virtual/jdk-1.5
+ app-arch/unzip"
+
+S="${WORKDIR}/glassfish"
+
+java_prepare() {
+ epatch "${FILESDIR}"/${P}-python2.7-sax-parser.patch #414807
+}
+
+EANT_BUILD_XML="persistence-api/build.xml"
+EANT_BUILD_TARGET="all"
+
+src_install() {
+ cd "${WORKDIR}"/publish/glassfish || die
+ java-pkg_newjar lib/javaee.jar
+
+ insinto /usr/share/${PN}/lib/schemas
+ doins lib/schemas/*.xsd
+}
diff --git a/dev-java/glassfish-persistence/metadata.xml b/dev-java/glassfish-persistence/metadata.xml
new file mode 100644
index 000000000000..407583277d87
--- /dev/null
+++ b/dev-java/glassfish-persistence/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+<maintainer>
+ <email>java@gentoo.org</email>
+</maintainer>
+</pkgmetadata>