summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-14 16:21:06 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-14 16:57:49 +0200
commit2b7ec681b2bdab87f6c3ea1e9ec6d2ad9bc9e30e (patch)
treed3a769f50cfb4ff8336b494f267be3a371e0d4f1 /dev-lang/python-exec
parentdev-python/dulwich: Add a hack removal die (diff)
downloadgentoo-2b7ec681b2bdab87f6c3ea1e9ec6d2ad9bc9e30e.tar.gz
gentoo-2b7ec681b2bdab87f6c3ea1e9ec6d2ad9bc9e30e.tar.bz2
gentoo-2b7ec681b2bdab87f6c3ea1e9ec6d2ad9bc9e30e.zip
dev-lang/python-exec: Add py3.12 to host test impls
Closes: https://bugs.gentoo.org/929402 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-lang/python-exec')
-rw-r--r--dev-lang/python-exec/python-exec-2.4.10.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/dev-lang/python-exec/python-exec-2.4.10.ebuild b/dev-lang/python-exec/python-exec-2.4.10.ebuild
index 05556b1b0d4e..077b27e7d539 100644
--- a/dev-lang/python-exec/python-exec-2.4.10.ebuild
+++ b/dev-lang/python-exec/python-exec-2.4.10.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
inherit python-any-r1
DESCRIPTION="Python script wrapper"
@@ -19,11 +20,13 @@ RESTRICT="!test? ( test )"
RDEPEND="
dev-lang/python-exec-conf
- !<=dev-lang/python-2.7.18-r3:2.7"
+ !<=dev-lang/python-2.7.18-r3:2.7
+"
BDEPEND="
test? (
$(python_gen_any_dep 'dev-python/pytest[${PYTHON_USEDEP}]')
- )"
+ )
+"
python_check_deps() {
python_has_version -b "dev-python/pytest[${PYTHON_USEDEP}]"