summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-09 23:36:51 +0000
committerSam James <sam@gentoo.org>2022-05-09 23:36:51 +0000
commit62f0eea1054b7db5a761b03957c57e53ee2b070a (patch)
tree500c0e007a362701a2bc95e5a6e6a9e4e93f54bd /dev-lang/python
parentmedia-plugins/alsa-plugins: avoid parallel install failure (diff)
downloadgentoo-62f0eea1054b7db5a761b03957c57e53ee2b070a.tar.gz
gentoo-62f0eea1054b7db5a761b03957c57e53ee2b070a.tar.bz2
gentoo-62f0eea1054b7db5a761b03957c57e53ee2b070a.zip
dev-lang/python: add -j1 in install to 3.11.0_beta1
Not doing it just for PGO as I don't know if it's exclusive to that, or just more likely there. Obviously just a temporary thing. Bug: https://bugs.gentoo.org/843458 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang/python')
-rw-r--r--dev-lang/python/python-3.11.0_beta1-r1.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/dev-lang/python/python-3.11.0_beta1-r1.ebuild b/dev-lang/python/python-3.11.0_beta1-r1.ebuild
index b26c9312a617..1afeef7be7a4 100644
--- a/dev-lang/python/python-3.11.0_beta1-r1.ebuild
+++ b/dev-lang/python/python-3.11.0_beta1-r1.ebuild
@@ -329,7 +329,8 @@ src_test() {
src_install() {
local libdir=${ED}/usr/lib/python${PYVER}
- emake DESTDIR="${D}" altinstall
+ # -j1 hack for now for bug #843458
+ emake -j1 DESTDIR="${D}" altinstall
# Fix collisions between different slots of Python.
rm "${ED}/usr/$(get_libdir)/libpython3.so" || die