summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-09-18 03:52:07 +0100
committerSam James <sam@gentoo.org>2024-09-18 03:55:28 +0100
commitc5ffa34a34acbd878f6277c519ce0c6c8852bfa6 (patch)
tree3e4768e12dc500a377e13b97979c414aed71554d /dev-lang/rust
parentdev-lang/rust-bin: drop USE=profiler in 1.81.0 (diff)
downloadgentoo-c5ffa34a34acbd878f6277c519ce0c6c8852bfa6.tar.gz
gentoo-c5ffa34a34acbd878f6277c519ce0c6c8852bfa6.tar.bz2
gentoo-c5ffa34a34acbd878f6277c519ce0c6c8852bfa6.zip
dev-lang/rust: drop obsolete rust-demangler bits from 1.81.0
This was dropped in upstream commit fd4fe7d129cac2b7a0668847117775ee23031771. See https://github.com/rust-lang/rust/pull/125880. rust-demangler is no more. Note that we keep USE=profiler as it still seems to be used for other bits like the profiling runtime. Bug: https://bugs.gentoo.org/939669 Closes: https://bugs.gentoo.org/939701 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang/rust')
-rw-r--r--dev-lang/rust/rust-1.81.0.ebuild5
1 files changed, 0 insertions, 5 deletions
diff --git a/dev-lang/rust/rust-1.81.0.ebuild b/dev-lang/rust/rust-1.81.0.ebuild
index b6837f265a6f..5634139adde1 100644
--- a/dev-lang/rust/rust-1.81.0.ebuild
+++ b/dev-lang/rust/rust-1.81.0.ebuild
@@ -342,7 +342,6 @@ src_configure() {
local tools='"cargo","rustdoc"'
use clippy && tools+=',"clippy"'
use miri && tools+=',"miri"'
- use profiler && tools+=',"rust-demangler"'
use rustfmt && tools+=',"rustfmt"'
use rust-analyzer && tools+=',"rust-analyzer","rust-analyzer-proc-macro-srv"'
use rust-src && tools+=',"src"'
@@ -685,7 +684,6 @@ src_install() {
use clippy && symlinks+=( clippy-driver cargo-clippy )
use miri && symlinks+=( miri cargo-miri )
- use profiler && symlinks+=( rust-demangler )
use rustfmt && symlinks+=( rustfmt cargo-fmt )
use rust-analyzer && symlinks+=( rust-analyzer )
@@ -744,9 +742,6 @@ src_install() {
echo /usr/bin/miri >> "${T}/provider-${P}"
echo /usr/bin/cargo-miri >> "${T}/provider-${P}"
fi
- if use profiler; then
- echo /usr/bin/rust-demangler >> "${T}/provider-${P}"
- fi
if use rustfmt; then
echo /usr/bin/rustfmt >> "${T}/provider-${P}"
echo /usr/bin/cargo-fmt >> "${T}/provider-${P}"