summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-09-22 14:58:22 +0100
committerSam James <sam@gentoo.org>2024-09-22 14:58:22 +0100
commit228410dfe66b2f9b6c738675c1ad5656d9235aed (patch)
tree4883f585e5fe200e1dfb81fa849ff9be41c1143a /dev-lang/swig
parentvirtual/perl-Encode: Stabilize 3.210.0-r1 hppa, #938570 (diff)
downloadgentoo-228410dfe66b2f9b6c738675c1ad5656d9235aed.tar.gz
gentoo-228410dfe66b2f9b6c738675c1ad5656d9235aed.tar.bz2
gentoo-228410dfe66b2f9b6c738675c1ad5656d9235aed.zip
dev-lang/swig: build with -fPIC, not -fpic
This fixes tests on hppa, sparc. Closes: https://bugs.gentoo.org/900769 Closes: https://bugs.gentoo.org/935318 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang/swig')
-rw-r--r--dev-lang/swig/swig-4.2.1.ebuild11
1 files changed, 11 insertions, 0 deletions
diff --git a/dev-lang/swig/swig-4.2.1.ebuild b/dev-lang/swig/swig-4.2.1.ebuild
index 1375557b544c..114ecb465943 100644
--- a/dev-lang/swig/swig-4.2.1.ebuild
+++ b/dev-lang/swig/swig-4.2.1.ebuild
@@ -27,6 +27,17 @@ BDEPEND="virtual/pkgconfig"
DOCS=( ANNOUNCE CHANGES CHANGES.current README TODO )
+PATCHES=(
+ "${FILESDIR}"/${P}-tests-fpic.patch
+)
+
+src_prepare() {
+ default
+
+ # Delete after 4.2.1 (bug #900769, bug #935318)
+ sed -i -e 's:fpic:fPIC:' configure.ac configure || die
+}
+
src_configure() {
# TODO: add USE for various langs? (https://bugs.gentoo.org/921504#c3)
econf \